Plantronics + Polycom. Now together as Poly Logo

VVX600 Pin authentication on Lync2013 not working

Folkert
Advisor

VVX600 Pin authentication on Lync2013 not working

Hi, I have an issue with an VVX600 on a Lync2013 installation. It is running 5.1.2. Logging in with username and password works perfectly. When trying with extension and pin it won't log in. Using the same extension and pin on a Aastra phone on the same subnet is working, Aastra will login using pin authentication. Option 43 and 120 are set. In the logs of the VVX it tells me it has problems getting the STSURI from option 43. But I don't get any more logging from it, debug level is not telling why it's not working. Testing the DHCP options with the Microsoft tool in that subnet shows everything is fine, all options are set. How can I get more information why the VVX is not finding those options? And why is it working on a Aastra? Hope someone can get me going, I've spend 2 days on this issue, reading all articles about option 43 and 120.

 

Regards,

 

Folkert

Message 1 of 12
11 REPLIES 11
SteffenBaierUK
Polycom Employee & Community Manager

Re: VVX600 Pin authentication on Lync2013 not working

Hello Folkert,

welcome to the Polycom Community.

There are additional logging levels that our Support team would provide you with.

 

Can you create the below and import via the Web Interface ?

 

<LYNC 	log.level.change.tickt="0"
		log.level.change.sip="0"
		log.render.file.size="128"
		log.render.file.upload.append.sizeLimit="100000"
		log.render.level="0"/>

 

Above requires the phone to be able to write to the provisioning server.

 

  • Is this a Microsoft DHCP Server or another party ?

Once you have the logs please raise a ticket with Polycom support via your Polycom reseller.


Please ensure to provide some feedback if this reply has helped you so other users can profit from your experience.

Best Regards

Steffen Baier

Polycom Global Services

----------------
The title Polycom Employee & Community Manager is a community setting and does not reflect my role. I am just a simple volunteer in the community like everybody else. My official "day" Job is 3rd Level support at Poly but I am unable to provide official support via the community.

----------------

Notice: This community forum is not an official Poly support resource, thus responses from Poly employees, partners, and customers alike are best-effort in attempts to share learned knowledge. If you need immediate and/or official assistance please open a service ticket through your proper support channels.
Please also ensure you always check the VoIP , Video Endpoint , Skype for Business , PSTN or RPM FAQ's
Message 2 of 12
Folkert
Advisor

Re: VVX600 Pin authentication on Lync2013 not working

 

Well, that didn't do much for me. response 3 code 0....

 

0918144350|tickt|0|00|[soWebTicketClearUserData]:Clearing the BackOffTimers
0918144350|so   |4|00|[soRegistrationC] Login Credentials valid causing SoRegEventLine Changed
0918144352|app1 |*|00|SoRegistrationEventLineChanged - success lineIndex 0 RegListSize 0
0918144352|app1 |*|00|SoRegistrationEventLast - new AppRegLineC, Default user
0918144405|sip  |*|00|dhcpOption120LyncQuery
0918144405|tickt|1|00|soWebticketGetAllUserInfo:input parameters user index 0, Extension 5003 server  UUID 01c62319-5e24-561b-a582-b454c1e6f1e9
0918144405|utilm|4|00|uBLFUnCompressed: File /ffs0/Config/Local/WebTicket/0/certProvSvc.mex doesn't exist or is empty
0918144405|tickt|1|00|soWebTicketServersGet: request URI is /mex
0918144405|tickt|1|00|Provisoning:Cipher suite = RSA:!EXP:!LOW:!NULL:!MD5:@STRENGTH
0918144405|tickt|1|00|soWebTicketServersGet: Got response 3 code 0
0918144405|tickt|0|00|Got response 3 code 0 data&colon;
(null)
 
(done)
0918144405|tickt|5|00|soWebticketGetAllUserInfo: soWebTicketServersGet Failed
0918144405|sip  |3|00|SipSetOption nIndex 39, nParam 4
0918144405|sip  |3|00|SipSetOption nIndex 78, nParam 1
0918144405|sip  |3|00|SipSetOption nIndex 79, nParam 3
0918144405|sip  |3|00|SipSetOption nIndex 80, nParam 1
0918144405|sip  |3|00|SipReloadMediaConfig
0918144405|sip  |*|00|Sip Register Usr:VVX600 Dsp:VVX 600 Auth:'Using Login Cred' Inx:0
0918144405|sip  |1|00|clearBossAdminLists - No of Admins -0, No Of Boss - 0
0918144405|sip  |1|00|clearBossAdminUsers - No of Admin Users -0, No Of Boss Users - 0
0918144405|sip  |3|00|SipOnEvProxyList 0,Total proxy 0
0918144405|sip  |3|00|SipSetOption nIndex 12, nParam 1127494944
0918144405|sip  |3|00|AddEmergencyRoute 911 0 0 0

 

Message 3 of 12
SteffenBaierUK
Polycom Employee & Community Manager

Re: VVX600 Pin authentication on Lync2013 not working

Hello Folkert,

the log shows the root cause:

 

0918144405|tickt|1|00|soWebTicketServersGet: request URI is /mex

 

Above should show your Web Ticket URL.

 

Example:

 

202646.012|tickt|1|00|soWebTicketServersGet: request URI is https://lyncfe01.t3voipuk.lab:443/CertProv/CertProvisioningService.svc/mex

Your DHCP Option 43 / 120 is therefore incorrectly setup. 

 

When you initiate the Pin & Extension sign in the Phone will send a DHCP INFORM to the DHCP Server and request via Option: (55) Parameter Request List the Parameter Request List Item: (43) Vendor-Specific Information.

 

The phone will identify itself via the Option: (60) Vendor class identifier as a Vendor class identifier: MS-UC-Client.

 

The DHCP server will reply with an ACK.

 

The reply contains the Option: (43) Vendor-Specific Information,

 

In my example:

 

MS-UC-Clienthttpslyncfe01.t3voipuk.lab443%/CertProv/CertProvisioningService.svcNAP

 

And the Option: (120) SIP Servers

 

In my example:

 

lyncfe01.t3voipuk.lab

 

This is an issue in your Network and you would require support from Microsoft on this.

 

Please ensure to provide some feedback if this reply has helped you so other users can profit from your experience.

Best Regards

Steffen Baier

Polycom Global Services

----------------
The title Polycom Employee & Community Manager is a community setting and does not reflect my role. I am just a simple volunteer in the community like everybody else. My official "day" Job is 3rd Level support at Poly but I am unable to provide official support via the community.

----------------

Notice: This community forum is not an official Poly support resource, thus responses from Poly employees, partners, and customers alike are best-effort in attempts to share learned knowledge. If you need immediate and/or official assistance please open a service ticket through your proper support channels.
Please also ensure you always check the VoIP , Video Endpoint , Skype for Business , PSTN or RPM FAQ's
Message 4 of 12
Folkert
Advisor

Re: VVX600 Pin authentication on Lync2013 not working

Hi Steffen,

 

I also assume the problem is in the option 43, but as I said, testing the the Lync DHCP tool gives everything ok. So I think the Microsoft DHCP server is working like it should be. And the Aastra is  working. Looking in the logs of the Aastra I see the correct configured url's and sip servers. Biggest problem is that I can't find what the Polycom is getting from DHCP, it simply isn't logged. I will now try an older firmware v4.1.2, hopefully there is more logging in there. Maybe it has something to do with the vlan lldp config.


Regards,

 

Folkert

Message 5 of 12
SteffenBaierUK
Polycom Employee & Community Manager

Re: VVX600 Pin authentication on Lync2013 not working

Hello Folkert,,

there is not any more logging in older firmware versions. Enhanced logging will only come with the next 5.2.0 or 5.3.0

 

You will need to setup wireshark and then follow the FAQ post on how to use this from the phone to capture the data.

 

I will update another FAQ post shortly to outline the relevant steps.

 

Best Regards

Steffen Baier

Polycom Global Services

----------------
The title Polycom Employee & Community Manager is a community setting and does not reflect my role. I am just a simple volunteer in the community like everybody else. My official "day" Job is 3rd Level support at Poly but I am unable to provide official support via the community.

----------------

Notice: This community forum is not an official Poly support resource, thus responses from Poly employees, partners, and customers alike are best-effort in attempts to share learned knowledge. If you need immediate and/or official assistance please open a service ticket through your proper support channels.
Please also ensure you always check the VoIP , Video Endpoint , Skype for Business , PSTN or RPM FAQ's
Message 6 of 12
SteffenBaierUK
Polycom Employee & Community Manager

Re: VVX600 Pin authentication on Lync2013 not working

Hello Volkert,

 

 

Please check => here <= and => here <=

Please ensure to provide some feedback if this reply has helped you so other users can profit from your experience.

Best Regards

Steffen Baier

Polycom Global Services

----------------
The title Polycom Employee & Community Manager is a community setting and does not reflect my role. I am just a simple volunteer in the community like everybody else. My official "day" Job is 3rd Level support at Poly but I am unable to provide official support via the community.

----------------

Notice: This community forum is not an official Poly support resource, thus responses from Poly employees, partners, and customers alike are best-effort in attempts to share learned knowledge. If you need immediate and/or official assistance please open a service ticket through your proper support channels.
Please also ensure you always check the VoIP , Video Endpoint , Skype for Business , PSTN or RPM FAQ's
Message 7 of 12
Folkert
Advisor

Re: VVX600 Pin authentication on Lync2013 not working

Hi Steffen,

 

making some wireshark traces made thing clear! The problem is the dhcp helper from our Sonicwall between the phone vlan and dhcp server. It seems the DHCP inform of the Polycom is something the Sonicwall doesn't understand. And why do the Aastra and dhcputil -Emulateclient work? They send a different DHCP inform package! They are sending it directly to the DHCP server that gave the ip address. The Polycom sends it as a broadcast. So there is the difference.

It looks like we can't fix the Sonicwall (terrible device). So now we will set up a DHCP server directly in the phone vlan. Or maybe there is a workaround in the Polycom? Is it possible to force it to send the DHCP inform package directly to the DHCP server instead of a broadcast?

Regards,

 

Folkert

Message 8 of 12
SteffenBaierUK
Polycom Employee & Community Manager

Re: VVX600 Pin authentication on Lync2013 not working

Hello Volkert,

I have raised this internally as I can verify that a CX600 phone for example only sends this as unicast.

 

Best Regards

Steffen Baier

Polycom Global Services

----------------
The title Polycom Employee & Community Manager is a community setting and does not reflect my role. I am just a simple volunteer in the community like everybody else. My official "day" Job is 3rd Level support at Poly but I am unable to provide official support via the community.

----------------

Notice: This community forum is not an official Poly support resource, thus responses from Poly employees, partners, and customers alike are best-effort in attempts to share learned knowledge. If you need immediate and/or official assistance please open a service ticket through your proper support channels.
Please also ensure you always check the VoIP , Video Endpoint , Skype for Business , PSTN or RPM FAQ's
Message 9 of 12
Folkert
Advisor

Re: VVX600 Pin authentication on Lync2013 not working

Hi Steffen,

 

thanks! Please let me know if there is more information from development (or whatever internal is :-) )

Regards,

 

Folkert

Message 10 of 12