Plantronics + Polycom. Now together as Poly Logo

Very close a provisioning server

ajkatz83
Visitor

Very close a provisioning server

Hello all:

I know the Soundpoint 601 has been EOL for eight years now, but I have had some great success in using it in the home office here, only issue is that the provisioning server I made over HTTP seems to have the right files version 3.18 and the phone does reach out and grab all necessary files needed to work, or so I thought, because it does update the boot ROM to 4.1.3 and does find the application. The only distressing thing in all the discovery is that when all the loading is done, the main screen is completely blank an after a few seconds just reboots over and over.

 

I don't know what this means or why the screen is just blank--no function keys no nothing displayed at all!! I know I am close I just have no idea what this means. I have tried downgrading, doesn't work, I have tried renaming config files to fit the schemes and nothing works. Has anyone come across this at all???

Message 1 of 8
7 REPLIES 7
SteffenBaierUK
Polycom Employee & Community Manager

Re: Very close a provisioning server

Hello @ajkatz83 ,

 

Welcome to the Poly Community.


As you have not posted any logs or anything for the community volunteers to work with I suggest this:

 

May 14, 2012 Question: Can I support a mix of legacy SIP and UCS Phones on the same Provisioning Server?
Resolution: Please check => here <=

 

Oct 7, 2011 Question: What is the relevance of the 000000000000.cfg or <mac>.cfg?

Resolution: Please check => here <=

 

Oct 7, 2011 Question: How can I setup my Phone / Provisioning / Download / Upgrade / Update / Downgrade Software?
Resolution: Please check => here <=

 

Please ensure to provide some feedback if this reply has helped you so other users can profit from your experience.

Best Regards

Steffen Baier

----------------
The title Polycom Employee & Community Manager is a community setting and does not reflect my role. I am just a simple volunteer in the community like everybody else. All posts and words are my own & do not represent the views of Employer.

----------------

Notice: This community forum is not an official Poly support resource, thus responses from Poly employees, partners, and customers alike are best-effort in attempts to share learned knowledge. If you need immediate and/or official assistance please open a service ticket through your proper support channels.
Please also ensure you always check the VoIP , Video Endpoint , Skype for Business , PSTN or RPM FAQ's
Message 2 of 8
ajkatz83
Visitor

Re: Very close a provisioning server

Hi Steffen:

 

I really cannot give any logs at all, for real, the display is totally blank--no softkeys or functionality to be had to go get a log at all. No web portal at all even though an IP address is given.

 

I have looked at all those articles already and none of it addresses what I am doing or what has happened. I keep using the BootROM 4.1.3 for the Soundpoint 601 and the sip_318.ld for the app, but it's strange when it's loaded that it's only shown as sip.ld.

 

I am communicating with the provisioning server I made with 3CX with their IP PBX and it's working but not sending the right configuration files I am assuming. I have included those I have mentioned in both posts but I don't know what else to do.

Message 3 of 8
SteffenBaierUK
Polycom Employee & Community Manager

Re: Very close a provisioning server

Hello @ajkatz83 ,

 

forget about any 3rd party server and set up a simple FTP server as shown in the FAQ example. Do not use a TFTP server either.

 

Follow the guides and once you have the phones running keep that setup.

 

EDIT: No files have ever been attached

 

Please ensure to provide some feedback if this reply has helped you so other users can profit from your experience.

Best Regards

Steffen Baier

----------------
The title Polycom Employee & Community Manager is a community setting and does not reflect my role. I am just a simple volunteer in the community like everybody else. All posts and words are my own & do not represent the views of Employer.

----------------

Notice: This community forum is not an official Poly support resource, thus responses from Poly employees, partners, and customers alike are best-effort in attempts to share learned knowledge. If you need immediate and/or official assistance please open a service ticket through your proper support channels.
Please also ensure you always check the VoIP , Video Endpoint , Skype for Business , PSTN or RPM FAQ's
Message 4 of 8
ajkatz83
Visitor

Re: Very close a provisioning server

I am not using any third party software at all. It's a strict HTTP server that has the files on it. The phone is communications and reading the files but then after the app is loaded it's just a blank screen. No softkeys, no time, no date, no functionality of the buttons at all, nothing. It just has it's lay out on the display and that's all!

 

I have used the guides and they are truly all over. I have a Soundpoint 601 and everything in those guides is talking about newer versions of IP phone I do not have at all.

 

This is my config file:

<?xml version="1.0" encoding="utf-8" standalone="yes"?>
<!-- Default Master SIP Configuration File-->
<!-- For information on configuring Polycom VoIP phones please refer to the -->
<!-- Configuration File Management white paper available from: -->
<!-- http://www.polycom.com/common/documents/whitepapers/configuration_file_management_on_soundpoint_ip_phones.pdf -->
<!-- $RCSfile$ $Revision: 125118 $ -->
<APPLICATION APP_FILE_PATH="sip.ld" CONFIG_FILES="phone1_318.cfg, sip_318.cfg" MISC_FILES="" LOG_FILE_DIRECTORY="" OVERRIDES_DIRECTORY="" CONTACTS_DIRECTORY="" LICENSE_DIRECTORY="">
<APPLICATION_SPIP300 APP_FILE_PATH_SPIP300="sip_212.ld" CONFIG_FILES_SPIP300="phone1_212.cfg, sip_212.cfg" />
<APPLICATION_SPIP301 APP_FILE_PATH_SPIP301="sip_318.ld" CONFIG_FILES_SPIP301="phone1_318.cfg, sip_318.cfg" />
<APPLICATION_SPIP430 APP_FILE_PATH_SPIP430="sip_318.ld" CONFIG_FILES_SPIP430="phone1_318.cfg, sip_318.cfg" />
<APPLICATION_SPIP500 APP_FILE_PATH_SPIP500="sip_212.ld" CONFIG_FILES_SPIP500="phone1_212.cfg, sip_212.cfg" />
<APPLICATION_SPIP501 APP_FILE_PATH_SPIP501="sip_318.ld" CONFIG_FILES_SPIP501="phone1_318.cfg, sip_318.cfg" />
<APPLICATION_SPIP600 APP_FILE_PATH_SPIP600="sip_318.ld" CONFIG_FILES_SPIP600="phone1_318.cfg, sip_318.cfg" />
<APPLICATION_SPIP601 APP_FILE_PATH_SPIP601="sip_318.ld" CONFIG_FILES_SPIP601="phone1_318.cfg, sip_318.cfg" />
<APPLICATION_SSIP4000 APP_FILE_PATH_SSIP4000="sip_318.ld" CONFIG_FILES_SSIP4000="phone1_318.cfg, sip_318.cfg" />
</APPLICATION>
Message 5 of 8
SteffenBaierUK
Polycom Employee & Community Manager

Re: Very close a provisioning server

Hello @ajkatz83 

 

as outlined use an FTP server to start with. That way you can check the logs and see what the phone is actually downloading and it "should" upload also logs.

 

This way you can troubleshoot these ancient phones.

 

Replied via a mobile device

----------------
The title Polycom Employee & Community Manager is a community setting and does not reflect my role. I am just a simple volunteer in the community like everybody else. All posts and words are my own & do not represent the views of Employer.

----------------

Notice: This community forum is not an official Poly support resource, thus responses from Poly employees, partners, and customers alike are best-effort in attempts to share learned knowledge. If you need immediate and/or official assistance please open a service ticket through your proper support channels.
Please also ensure you always check the VoIP , Video Endpoint , Skype for Business , PSTN or RPM FAQ's
Message 6 of 8
ajkatz83
Visitor

Re: Very close a provisioning server

Cant get the TFTP to work at all. I am not using Windows or Mac, it's all on RPi4. 

Message 7 of 8
SteffenBaierUK
Polycom Employee & Community Manager

Re: Very close a provisioning server

Hello @ajkatz83 ,

 

you need to use an OS where you can get some sort of logs and which also allows the device to upload its own logs.

 

As outlined use a windows machine with FileZilla FTP server and get us, volunteers, some logs.


Best Regards

Steffen Baier

----------------
The title Polycom Employee & Community Manager is a community setting and does not reflect my role. I am just a simple volunteer in the community like everybody else. All posts and words are my own & do not represent the views of Employer.

----------------

Notice: This community forum is not an official Poly support resource, thus responses from Poly employees, partners, and customers alike are best-effort in attempts to share learned knowledge. If you need immediate and/or official assistance please open a service ticket through your proper support channels.
Please also ensure you always check the VoIP , Video Endpoint , Skype for Business , PSTN or RPM FAQ's
Message 8 of 8