Plantronics + Polycom. Now together as Poly Logo

Voice and/or Data VLAN Segregation on Cisco Router and Switch where DHCP is provided by Cisco Router

mahaque
Occasional Visitor

Voice and/or Data VLAN Segregation on Cisco Router and Switch where DHCP is provided by Cisco Router

Dear All,

 

First of all thanks for looking into this thread. I am new to this forum. Hope someone can help me sort the solution I am looking forward.

 

Right now we are using no VLAN Tagging for our call center, we all are on cisco Default native VLAN. We are using Polycom Soundpoint IP 330 SIP. Cisco 3560G Switch 48POE and the IOS I am using version 12.2.

 

 

IN Call Center all Thin Client are connected to the Phone and and Phone is connected with Wall Socket > Switch.

 

I am quite lost on How we will implement the Data and Voice VLAN separate on Cisco and if there are any How to's on this specifically for Polycom Phone.

 

In detail, I wonder how the Phone will identify DHCP and later on the tagging to be responsive on SIP Calls. We are using G711a codec.

 

Woudl appreciate any workarround/ How to's to get this sorted.

 

Thanks again for your time and looking this matter.

 

Regards,

Mohammad

 

Message 1 of 2
1 REPLY 1
davem2626
Valued Contributor

Re: Voice and/or Data VLAN Segregation on Cisco Router and Switch where DHCP is provided by Cisco Ro

Hi mahaque

 

Not quite sure if you are wanting to enable vlans on your cisco switch or not? personally i think that method is better.

 

To enable vlans on your switch:

 

Switch1# configure terminal
Switch1(config)# vlan 2
Switch1(config-vlan)# name Voice
Switch1(config-vlan)# end
Switch1(config)# vlan 4
Switch1(config-vlan)# name Data
Switch1(config-vlan)# end

  

then assign voice and data access to each port:

 

Switch1(config)# interface range fastethernet0/1 -23
Switch1(config-if)# switchport mode access
Switch1(config-if)# switchport access vlan 2,4
Switch1(config-if)# end

 

 

Then set the DHCP scope for the voice vlan:

 

ip dhcp pool pool1
network 10.10.1.0 255.255.255.0
default-router 10.10.1.1
dns-server what.ever.ip.itis
!
vlan 2
 ip address 10.10.1.1 255.255.255.0

 

 

you can also specify your option 66 within the scope:

 

ip dhcp pool1
network 10.10.1.0 255.255.255.0
default-router 10.10.1.1
dns-server what.ever.ip.is
option 66 ascii "http://x.FQDN.com"
OR
option 66 ip 10.x.x.x
lease infinate

 

 

With both vlans tagged on the switchports this will enable the phones to pass on the data vlan to the connecting pc's and use the voice vlan for themselves.

 

I hope this helps with what answer you were trying to find...

 

Cheers

 

Dave

Message 2 of 2