Plantronics + Polycom. Now together as Poly Logo

dhcp and VLANs

Highlighted
Occasional Visitor

dhcp and VLANs

This should be easy, and I've don it a while back and it work fine. I've checked the documentation, maybe something has changed or maybe I'm just missing something.

 

I've stripped the environment down to a single Cisco 2960s with two VLANs with interfaces on different subnets. I have two dhcp pools, one for each subnet (I know I'm being overly specific). All the ports are configured as trunks with the only config line of "switchport mode trunk". DHCP option 66 is handed out just fine, but no matter what I try the VLAN ID, for the voice VLAN, isn't accepted by the phone. I say accepted because I've done a packet capture and the option is being sent. I'm testing with an IP550 originally at 4.0.1 now at 4.0.3, and a VVX500 at 4.0.1 (which also wouldn't pull down the update from the tftp server).

 

On both phones I've tried VLAN ID as Fixed and Custom, 128, 129, and 254. I've also tried 157 which is used by Adtran/Polycom phones and is formatted differently (figured it couldn't hurt). 

 

And to make it more confusing, way before I stripped it sown to this simple config and I wasn't on Cisco gear but was using basically  the same config, the IP550 worked through a couple resets, then stopped.

 

I'm open to any ideas.

Thanks all

 

 

Message 1 of 6
5 REPLIES 5
Highlighted
Polycom Employee & Community Manager

Re: dhcp and VLANs

Hello 179,

welcome to the Polycom Community.

The UCS 4.0.1 Admin Guide explains in the Chapter titeled "Assigning a VLAN ID Using DHCP" on page 366 in great detail how the DHCP discovery in regards of a Vlan is archived on a Polycom phone.

 

To assign a VLAN ID to a phone using DHCP:


In the DHCP menu of the Main setup menu, set VLAN Discovery to Fixed or Custom.

 

• When set to Fixed, the phone will examine DHCP options 128,144, 157 and 191 (in that order) for a valid DVD string.
• When set to Custom, a value set in the VLAN ID Option will be examined for a valid DVD string.

 

DVD string in the DHCP option must meet the following conditions to be valid:

 

• Must start with “VLAN-A=” (case-sensitive)
• Must contain at least one valid ID
• VLAN IDs range from 0 to 4095
• Each VLAN ID must be separated by a “+” character
• The string must be terminated by a semi colon “;”
• All characters after the semi colon “;” will be ignored
• There must be no white space before the semi colon “;”
• VLAN IDs may be decimal, hex, or octal


The following DVD strings will result in the phone using VLAN 10:

 

VLAN-A=10;
VLAN-A=0x0a;
VLAN-A=012;

 

  • Did you follow above recommendations ?
  • Does your DHCP server offer the required format of string?

Please ensure to provide some feedback if this reply has helped you so other users can profit from your experience.

Best Regards

Steffen Baier

Polycom Global Services

----------------
The title Polycom Employee & Community Manager is a community setting and does not reflect my role. I am just a simple volunteer in the community like everybody else. My official "day" Job is 3rd Level support at Poly but I am unable to provide official support via the community.

----------------

Notice: This community forum is not an official Poly support resource, thus responses from Poly employees, partners, and customers alike are best-effort in attempts to share learned knowledge. If you need immediate and/or official assistance please open a service ticket through your proper support channels.
Please also ensure you always check the VoIP , Video Endpoint , Skype for Business , PSTN or RPM FAQ's
Message 2 of 6
Highlighted
Occasional Visitor

Re: dhcp and VLANs

Actually I've done all that, all the options (one at a time and all together), checked the format a dozen times, did a packet capture and confirmed that the dhcp server is sending the options. BTW we've setup a third system and got the same results, this one is all VVX500 connected to an Adtran 3448 which is providing dhcp.

Message 3 of 6
Highlighted
Polycom Employee & Community Manager

Re: dhcp and VLANs

Hello 179,

 

the next step is to contact your Polycom reseller to log a ticket with Polycom support.

 

Best regards

 

Steffen Baier

----------------
The title Polycom Employee & Community Manager is a community setting and does not reflect my role. I am just a simple volunteer in the community like everybody else. My official "day" Job is 3rd Level support at Poly but I am unable to provide official support via the community.

----------------

Notice: This community forum is not an official Poly support resource, thus responses from Poly employees, partners, and customers alike are best-effort in attempts to share learned knowledge. If you need immediate and/or official assistance please open a service ticket through your proper support channels.
Please also ensure you always check the VoIP , Video Endpoint , Skype for Business , PSTN or RPM FAQ's
Message 4 of 6
Highlighted
Occasional Visitor

Re: dhcp and VLANs

OK, so when I was on the Adtran the LLDP was causing the problem and when I moved to the Cisco to precifically remove this as a possability I introduced CDP, which caused the same problem. I suppose I could acomplish the same thing by disabling LLDP and CDP on the phones, but the goal is to do nothing on the individual phones. I'm going back to the manual to see if I can disable LLDP and CDP with DHCP options.

 

I'm sure it would help to use a current admin guide but the best I could find is the 3.3.0 admin guide. If someone has a link directly to the 4.x admin guide download that would be great.

 

Thanks

Message 5 of 6
Highlighted
Polycom Employee & Community Manager

Re: dhcp and VLANs

Hello 179,

 

how about => here <= ?

 

Admin Guide.PNG

 

Parameters can be set via the device.set option within the configuration files. The community search or Admin guide should show information / examples.

 

As a quick reminder, your Polycom reseller is your Tier 1 support contact. If this fails please follow up the advise within my signature.

 

Best regards

 

Steffen Baier

----------------
The title Polycom Employee & Community Manager is a community setting and does not reflect my role. I am just a simple volunteer in the community like everybody else. My official "day" Job is 3rd Level support at Poly but I am unable to provide official support via the community.

----------------

Notice: This community forum is not an official Poly support resource, thus responses from Poly employees, partners, and customers alike are best-effort in attempts to share learned knowledge. If you need immediate and/or official assistance please open a service ticket through your proper support channels.
Please also ensure you always check the VoIP , Video Endpoint , Skype for Business , PSTN or RPM FAQ's
Message 6 of 6