Plantronics + Polycom. Now together as Poly Logo

dialplan digitmap not working at all

SOLVED
Highlighted
Occasional Advisor

dialplan digitmap not working at all

Somewhere along the way the config template on the provisiong server lost the dialplan.

We put in the last know good dialplan but it doesnt seem to be working, even though it is getting picked up by the phones and showing up in the local config.

We have ucs 4.0.7 installed, mostly 335's.

 

Last know good config (200 is voicemail,3 digit extensions):

 

 <dialplan
    dialplan.digitmap="[2-9]xxxxxxxxx|[1]xxxxxxxxxx|200|911|0T|[1-8]xx.T|*xxxx|011x.T"
    dialplan.digitmap.timeout="3|3|3|3|3|3|3|3"
    dialplan.1.digitmap=""
    dialplan.1.digitmap.timeout=""
  />

 

I alos tried manually editing the digitmap on my phone to to just the very basic internal extension rule [1-8]xx.T and the phone just seems to be ignoring it.

Any help woiuld be appreciated.

Message 1 of 12
1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Polycom Employee & Community Manager

Re: dialplan digitmap not working at all

Hello Bogdan,

Yes UC Software 4.x.x is the latest.

 

Software Version  Call Server
4.0.X SIP Only
4.1.X LYNC Only


Please ensure to provide some feedback if this reply has helped you so other users can profit from your experience.

Best Regards

Steffen Baier

Polycom Global Services

----------------
The title Polycom Employee & Community Manager is a community setting and does not reflect my role. I am just a simple volunteer in the community like everybody else. My official "day" Job is 3rd Level support at Poly but I am unable to provide official support via the community.

----------------

Notice: This community forum is not an official Poly support resource, thus responses from Poly employees, partners, and customers alike are best-effort in attempts to share learned knowledge. If you need immediate and/or official assistance please open a service ticket through your proper support channels.
Please also ensure you always check the VoIP , Video Endpoint , Skype for Business , PSTN or RPM FAQ's

View solution in original post

Message 12 of 12
11 REPLIES 11
Highlighted
Polycom Employee & Community Manager

Re: dialplan digitmap not working at all

Hello Bogdan,

welcome back to the Polycom Community.

I suggest you download and install UC Software 4.0.11 first in order to be on a currently supported release.

 

You can then follow this:

 

Oct 7, 2011 Question: Phone unable to Dial a number when Off Hook or on 2nd Call in a Conference or Digitmap issues

Resolution: Please check => here <=

 

the above contains logging levels you can use to troubleshoot.

Please ensure to provide some feedback if this reply has helped you so other users can profit from your experience.

Best Regards

Steffen Baier

Polycom Global Services

----------------
The title Polycom Employee & Community Manager is a community setting and does not reflect my role. I am just a simple volunteer in the community like everybody else. My official "day" Job is 3rd Level support at Poly but I am unable to provide official support via the community.

----------------

Notice: This community forum is not an official Poly support resource, thus responses from Poly employees, partners, and customers alike are best-effort in attempts to share learned knowledge. If you need immediate and/or official assistance please open a service ticket through your proper support channels.
Please also ensure you always check the VoIP , Video Endpoint , Skype for Business , PSTN or RPM FAQ's
Message 2 of 12
Highlighted
Occasional Advisor

Re: dialplan digitmap not working at all

Hi Steffen, thanks for your quick reply.

I've updated to 4.0.11, changed my dialplan to what was in your article as well as turned the logging on support objects to Event 1.

The phone still does nothing when punching in any numbers, have to hit the dial button.

There is nothing in the logs, it just shows configuration applied successfully.

Below is the config snippet that includes the dialplan and the bit that turns off voicemail notification is working normally.

 

Any ideas where to go next with this?

    <!-- Dial Plan settings-->    
    <dialplan
        dialplan.digitmap="[2-9]11|0T|011xxx.T|[0-1][2-9]xxxxxxxxx|[2-9]xxxxxxxxx|[2-9]xxT"
        dialplan.digitmap.timeout="3|3|3|3|3|3"
        dialplan.1.digitmap=""
        dialplan.1.digitmap.timeout=""
    />
    
    <se
    se.rt.custom1.name="3CX Auto Answer"
    se.rt.custom1.ringer="default"
    se.rt.custom1.type="answer"
    />
    
    <!-- voIpProt.SIP.alertInfo.2 intentionally not used -->
    <voIpProt.SIP.alertInfo
    voIpProt.SIP.alertInfo.1.class="custom1"
    voIpProt.SIP.alertInfo.1.value="auto-answer"
    />


    <!-- Distingtive Ring Tone & Voice Mail Sound-->    
    <se>
        <se.pat>
            <se.pat.misc>
                <se.pat.misc.messageWaiting>
                    <se.pat.misc.messageWaiting.inst
                        se.pat.misc.messageWaiting.inst.1.value="0"/>
                </se.pat.misc.messageWaiting>
            </se.pat.misc>
        </se.pat>

    </se>
Message 3 of 12
Highlighted
Polycom Employee & Community Manager

Re: dialplan digitmap not working at all

Hello Bogdan,

Are you dialing on Hook aka no dialtone or of Hook aka dialtone playing?

Please ensure to provide some feedback if this reply has helped you so other users can profit from your experience.

Best Regards

Steffen Baier

Polycom Global Services

----------------
The title Polycom Employee & Community Manager is a community setting and does not reflect my role. I am just a simple volunteer in the community like everybody else. My official "day" Job is 3rd Level support at Poly but I am unable to provide official support via the community.

----------------

Notice: This community forum is not an official Poly support resource, thus responses from Poly employees, partners, and customers alike are best-effort in attempts to share learned knowledge. If you need immediate and/or official assistance please open a service ticket through your proper support channels.
Please also ensure you always check the VoIP , Video Endpoint , Skype for Business , PSTN or RPM FAQ's
Message 4 of 12
Highlighted
Occasional Advisor

Re: dialplan digitmap not working at all

Hi Steffen,

off hook(dialtone) works.

on hook(no dialtone, phone is idle) doesnt work.

Message 5 of 12
Highlighted
Polycom Employee & Community Manager

Re: dialplan digitmap not working at all

Hello Bogdan,

This is very simple. Dialing on hook is not run through the digitmap.

 

Please add this to your configuration:

 

dialplan.userDial.timeOut="3"

You can manipulate the time.


Please ensure to provide some feedback if this reply has helped you so other users can profit from your experience.

Best Regards

Steffen Baier

Polycom Global Services

----------------
The title Polycom Employee & Community Manager is a community setting and does not reflect my role. I am just a simple volunteer in the community like everybody else. My official "day" Job is 3rd Level support at Poly but I am unable to provide official support via the community.

----------------

Notice: This community forum is not an official Poly support resource, thus responses from Poly employees, partners, and customers alike are best-effort in attempts to share learned knowledge. If you need immediate and/or official assistance please open a service ticket through your proper support channels.
Please also ensure you always check the VoIP , Video Endpoint , Skype for Business , PSTN or RPM FAQ's
Message 6 of 12
Highlighted
Occasional Advisor

Re: dialplan digitmap not working at all

Now im getting the error below:

.cfg: Unknown parameter "dialplan.userdial.timeout" found, ignoring.

 

It should be in the dialplan block, correct?

  

<dialplan
        dialplan.digitmap="[2-9]11|0T|011xxx.T|[0-1][2-9]xxxxxxxxx|[2-9]xxxxxxxxx|[2-9]xxT"
        dialplan.digitmap.timeout="3|3|3|3|3|3"
        dialplan.1.digitmap=""
        dialplan.1.digitmap.timeout=""
        dialplan.userdial.timeout="3"        
    />
Message 7 of 12
Highlighted
Polycom Employee & Community Manager

Re: dialplan digitmap not working at all

Hello Bogdan,

apologize, I overlooked you where using an older version.

 

You cannot use this parameter.


Please ensure to provide some feedback if this reply has helped you so other users can profit from your experience.

Best Regards

Steffen Baier

Polycom Global Services

----------------
The title Polycom Employee & Community Manager is a community setting and does not reflect my role. I am just a simple volunteer in the community like everybody else. My official "day" Job is 3rd Level support at Poly but I am unable to provide official support via the community.

----------------

Notice: This community forum is not an official Poly support resource, thus responses from Poly employees, partners, and customers alike are best-effort in attempts to share learned knowledge. If you need immediate and/or official assistance please open a service ticket through your proper support channels.
Please also ensure you always check the VoIP , Video Endpoint , Skype for Business , PSTN or RPM FAQ's
Message 8 of 12
Highlighted
Occasional Advisor

Re: dialplan digitmap not working at all

Hi Steffen,

Im not against upgrading firmware if it will work... whats the minimum firmware for these 335's that will support that feature?

Message 9 of 12
Highlighted
Polycom Employee & Community Manager

Re: dialplan digitmap not working at all

Hello Bogdan,

You cannot upgrade to a version that has this feature. Unfortunately you need to live with this.

Best Regards

Steffen Baier

Polycom Global Services

----------------
The title Polycom Employee & Community Manager is a community setting and does not reflect my role. I am just a simple volunteer in the community like everybody else. My official "day" Job is 3rd Level support at Poly but I am unable to provide official support via the community.

----------------

Notice: This community forum is not an official Poly support resource, thus responses from Poly employees, partners, and customers alike are best-effort in attempts to share learned knowledge. If you need immediate and/or official assistance please open a service ticket through your proper support channels.
Please also ensure you always check the VoIP , Video Endpoint , Skype for Business , PSTN or RPM FAQ's
Message 10 of 12