Plantronics + Polycom. Now together as Poly Logo

ldap corporate directory

Occasional Visitor

ldap corporate directory

I am trying to configure an ldap query to setup a corporate directory. I was given an example to work with. I got it to work, but it also includes former employees. I want to exclude certain OUs or only query certain OUs. 

The example is here:

<?xml version="1.0" encoding="utf-8" standalone="yes"?>
<!-- LDAP Example for Active Directorty Server -->
    <sort dir.corp.sortControl="0" />
    <vlv dir.corp.vlv.allow="0" />
    <cache dir.corp.pageSize="16" dir.corp.cacheSize="64" />
    <addr dir.corp.address="ldap://" dir.corp.port="389" dir.corp.transport="tcp" />
    <baseDN dir.corp.baseDN="dc=t2voice,dc=tech-support,dc=lab" dir.corp.filterPrefix="(objectclass=person)(!(objectclass=computer))(telephoneNumber=*)" dir.corp.scope="sub" />
    <sync dir.corp.backGroundSync="1" dir.corp.backGroundSync.period="3600" />
    <view dir.corp.viewPersistence="0" />
    <attr1"sn" dir.corp.attribute.1.label="Last Name" dir.corp.attribute.1.type="last_name " dir.corp.attribute.1.filter="" dir.corp.attribute.1.sticky="0" />
    <attr2"givenName" dir.corp.attribute.2.label="First Name" dir.corp.attribute.2.type="first_name" dir.corp.attribute.2.filter="" dir.corp.attribute.2.sticky="0" dir.corp.attribute.2.searchable="0" />
    <attr3"telephoneNumber" dir.corp.attribute.3.label="Phone Number" dir.corp.attribute.3.type="phone_number" dir.corp.attribute.3.filter="" dir.corp.attribute.3.sticky="0" />
    <login dir.corp.user="" dir.corp.password="T3ch!ab" feature.corporateDirectory.enabled="1"/>

I added the OUs to this line:
<baseDN dir.corp.baseDN="dc=t2voice,dc=tech-support,dc=lab

such as <baseDN dir.corp.baseDN="ou=users,ou=california,dc=t2voice,dc=tech-support,dc=lab
This is not working. How do I get it to do what I want it to do? I do not see anything in the documentation for this.

Message 1 of 1