Plantronics + Polycom. Now together as Poly Logo

ldap invalid DN syntax

Occasional Visitor

ldap invalid DN syntax

I'm trying to set up the ldap corporate directory, but the corp dir on the phone only says please try again, looking at the syslog output, I see:

 

Jul 20 16:55:12 192.168.80.137 192.168.80.137 0720165508|ldap |4|00|ldapData::ldapConnBind:ldap_x_bind_s - rc=0x22 <Invalid DN syntax>
Jul 20 16:55:12 192.168.80.137 192.168.80.137 0720165508|ldap |4|00|cDynamicData::finalizeInit:finalizeInit Failed state=<2>

The ldap server is well established and working, my config is:

 

<dir>
  <dir.corp dir.corp.address="ldap://192.168.70.12"
  dir.corp.baseDN="ou=Staff,dc=autologic"
  dir.corp.filterPrefix="(objectclass=inetorgPerson)">
    <dir.corp.attribute
       dir.corp.attribute.1.filter=""
       dir.corp.attribute.1.label="Last Name"
       dir.corp.attribute.1.name="sn"
       dir.corp.attribute.1.searchable="0"
       dir.corp.attribute.1.sticky="0"
       dir.corp.attribute.1.type="last_name"
       dir.corp.attribute.2.filter=""
       dir.corp.attribute.2.label="First Name"
       dir.corp.attribute.2.name="gn"
       dir.corp.attribute.2.searchable="0"
       dir.corp.attribute.2.sticky="0"
       dir.corp.attribute.2.type="first_name"
       dir.corp.attribute.3.filter=""
       dir.corp.attribute.3.label="Tel Number"
       dir.corp.attribute.3.name="telephoneNumber"
       dir.corp.attribute.3.searchable="0"
       dir.corp.attribute.3.sticky="0"
       dir.corp.attribute.3.type="phone_number">
    </dir.corp.attribute>
    <dir.corp.backGroundSync dir.corp.backGroundSync.period="86400">
    </dir.corp.backGroundSync>
    <dir.corp.vlv dir.corp.vlv.allow="0" dir.corp.vlv.sortOrder="">
    </dir.corp.vlv>
  </dir.corp>
</dir>


Message 1 of 5
4 REPLIES 4
Polycom Employee & Community Manager

Re: ldap invalid DN syntax

Hello Niall,

Have a look at the corporate directory FAQ and maybe lower the ldap logging level to 2

Best regards

Steffen Baier



<======== Signature / Disclaimer ========>
Please be aware:For questions about the type of support to expect please check here

Please also ensure you always check the VoIP , Video Endpoint , Skype for Business , PSTN or RPM FAQ's

Please remember, if you see a post that helped you , and it answers your question, please mark it as an "Accept as Solution".

The title Polycom Employee & Community Manager is an automatic setting within the community and any forum reply or post is based upon my personal experience and does not reflect the opinion or view of my employer.
Poly employee participation within this community is not mandatory and any post or FAQ article provided by myself is done either during my working hours or outside working hours, in my private time, and maybe answered on weekends, bank holidays or personal holidays.
Message 2 of 5
Occasional Visitor

Re: ldap invalid DN syntax

I used the following syntax and was able to get to work. The issue was the naming which I have highlighted in red.  

 

I am using Polycom 670 and 4.0

 

<dir>
  <dir.corp dir.corp.address="ldap://192.168.70.12"
  dir.corp.baseDN="ou=Staff,dc=autologic"
  dir.corp.filterPrefix="(objectclass=inetorgPerson)">
    <dir.corp.attribute
       dir.corp.attribute.1.filter=""
       dir.corp.attribute.1.label="Last name"
       dir.corp.attribute.1.name="sn"
       dir.corp.attribute.1.searchable="0"
       dir.corp.attribute.1.sticky="0"
       dir.corp.attribute.1.type="last_name"
       dir.corp.attribute.2.filter=""
       dir.corp.attribute.2.label="First name"
       dir.corp.attribute.2.name="givenName"
       dir.corp.attribute.2.searchable="0"
       dir.corp.attribute.2.sticky="0"
       dir.corp.attribute.2.type="first_name"
       dir.corp.attribute.3.filter=""
       dir.corp.attribute.3.label="phone number"
       dir.corp.attribute.3.name="telephoneNumber"
       dir.corp.attribute.3.searchable="0"
       dir.corp.attribute.3.sticky="0"
       dir.corp.attribute.3.type="phone_number">
    </dir.corp.attribute>
    <dir.corp.backGroundSync dir.corp.backGroundSync.period="86400">
    </dir.corp.backGroundSync>
    <dir.corp.vlv dir.corp.vlv.allow="0" dir.corp.vlv.sortOrder="">
    </dir.corp.vlv>
  </dir.corp>
</dir>

Message 3 of 5
Polycom Employee & Community Manager

Re: ldap invalid DN syntax

Hello sangar,

welcome to the Polycom Community.

Thanks for getting back but these are just the labels the phone displays on the screen. The FAQ contains a working example and the original user has unfortunately not yet replied.

Best Regards

Steffen Baier

Polycom Global Services




<======== Signature / Disclaimer ========>
Please be aware:For questions about the type of support to expect please check here

Please also ensure you always check the VoIP , Video Endpoint , Skype for Business , PSTN or RPM FAQ's

Please remember, if you see a post that helped you , and it answers your question, please mark it as an "Accept as Solution".

The title Polycom Employee & Community Manager is an automatic setting within the community and any forum reply or post is based upon my personal experience and does not reflect the opinion or view of my employer.
Poly employee participation within this community is not mandatory and any post or FAQ article provided by myself is done either during my working hours or outside working hours, in my private time, and maybe answered on weekends, bank holidays or personal holidays.
Message 4 of 5
Occasional Visitor

Re: ldap invalid DN syntax

When incroporated the sytax that you have provided in FAQ, I was getting an error "Try Again". As soon i changed them to what I supplied, it started to work. I have it working curently with my configuration. Perhaps I am nissing some other parameter

 

Message 5 of 5