Plantronics + Polycom. Now together as Poly Logo

up.analogHeadset problem

Frederi
Occasional Contributor

up.analogHeadset problem

I rollout 100 sets IP 335 with JABRA 9460 headsets including EHS cable.

 

We configure the sets via TFTP with the headset enabled, JABRA configured and language set to Dutch.

 

All settings are loaded, except the JABRA configuration that we do via up.analogHeadset=1

 

First the set loads <mac>.cfg.

Then <mac>-phone.cfg that contains the line:

 

<user_preferences up.analogHeadsetOption="1" up.offHookAction.none="" up.pictureFrame.folder="" up.pictureFrame.timePerImage="" up.screenSaver.enabled="0" up.screenSaver.waitTime="" />

 

Then <company.cfg> that contains the lines:

 

    <multilingual>
       <language lcl.ml.lang="Dutch_Netherlands" />
    </multilingual>

 

  <!-- headsetMode=1 = Jabra headset: -->
  <user_preferences
 up.analogHeadsetOption="1"
 up.headsetMode="1"
 up.useDirectoryNames="0"
 up.oneTouchVoiceMail="0"
 up.localClockEnabled="1"
 up.mwiVisible="1"
 up.idleTimeout=""
 up.handsfreeMode="1"
   />

 

We see the language loade, headsetmode set to 1 but the analogHeadsetOption still to 0 instead of 1

 

Here the device details:

 

Soundpoint IP335

Bootblock 3.0.2.0024

BootROM 4.3.0.0246

SIP 3.2.7.0198

 

Can anyone help me out.

 

Kind regards, Frederik Moquette

8 REPLIES 8
SteffenBaierUK
Polycom Employee & Community Manager

Re: up.analogHeadset problem

Hello Fredery,

welcome to the Polycom Community.

Did you attempt and set this setting manually on the Phone and then reboot the Phone to see if this works?

 

I found some internal reference that there may be an issue that was found when using option "2" but I am not aware that option "1" is also causing an issue.

 

Could you first try to manually activate & reboot and then test ?

 

If above does not work please do the following:

 

"Disable" the Serial Port:

 

1.Go to BootROM Setup menu and then go to Serial Port option
2.Press "Edit" soft key and change the option to "Disable"
3.Press "Ok" soft key and then press "Exit" soft key
4.Select "Save & Reboot" option. Phone reboots.

 

Please ensure to provide some feedback if this reply has helped you so other users can profit from your experience.


Best Regards

Steffen Baier

Polycom Global Services

----------------
The title Polycom Employee & Community Manager is a community setting and does not reflect my role. I am just a simple volunteer in the community like everybody else. All posts and words are my own & do not represent the views of Employer.

----------------

Notice: This community forum is not an official Poly support resource, thus responses from Poly employees, partners, and customers alike are best-effort in attempts to share learned knowledge. If you need immediate and/or official assistance please open a service ticket through your proper support channels.
Please also ensure you always check the VoIP , Video Endpoint , Skype for Business , PSTN or RPM FAQ's
Message 2 of 9
Frederi
Occasional Contributor

Re: up.analogHeadset problem

Hi Steffen,

 

Thanks for the quick respons.

 

Manually we can set the configuration to Jabra, similar to headsetoption 1. Then it works.


We did a test with loading while the serial port was disabled, then it loads the option correct. However:

 

- once the serial port has been disabled, will the EHS connection between Polycom and Jabra still work?

- the amount of effort to disable the serial port via the bootrom menu is similar to setting the headsetoption manually to Jabra. Is there a way to automate the whole process without the need of manual configuartion first?

 

Kind regards,

 

Frederik Moquette

Message 3 of 9
SteffenBaierUK
Polycom Employee & Community Manager

Re: up.analogHeadset problem

Hello Frederik,

 

please contact me per community mail so we can discuss this further.

 

Once we have found a solution I will update this topic.

 

Best Regards

 

Steffen Baier

----------------
The title Polycom Employee & Community Manager is a community setting and does not reflect my role. I am just a simple volunteer in the community like everybody else. All posts and words are my own & do not represent the views of Employer.

----------------

Notice: This community forum is not an official Poly support resource, thus responses from Poly employees, partners, and customers alike are best-effort in attempts to share learned knowledge. If you need immediate and/or official assistance please open a service ticket through your proper support channels.
Please also ensure you always check the VoIP , Video Endpoint , Skype for Business , PSTN or RPM FAQ's
Message 4 of 9
escaux
Visitor

Re: up.analogHeadset problem

Dear,

 

I have the same issue. Did you find a solution to this problem ?

 

Thanks in advance,

Message 5 of 9
SteffenBaierUK
Polycom Employee & Community Manager

Re: up.analogHeadset problem

Hello escaux,

welcome to the Polycom Community.

The second reply contains the current solution and the original poster confirmed that this worked for himself.

Please ensure to provide some feedback if this reply has helped you so other users can profit from your experience.

Best Regards

Steffen Baier

Polycom Global Services

----------------
The title Polycom Employee & Community Manager is a community setting and does not reflect my role. I am just a simple volunteer in the community like everybody else. All posts and words are my own & do not represent the views of Employer.

----------------

Notice: This community forum is not an official Poly support resource, thus responses from Poly employees, partners, and customers alike are best-effort in attempts to share learned knowledge. If you need immediate and/or official assistance please open a service ticket through your proper support channels.
Please also ensure you always check the VoIP , Video Endpoint , Skype for Business , PSTN or RPM FAQ's
Message 6 of 9
escaux
Visitor

Re: up.analogHeadset problem

Dear,

 

Thank you for your response but...

 

The solution provided requires a manual action.I would like to avoid that.

 

And, to quote one of the previous post, "the amount of effort to disable the serial port via the bootrom menu is similar to setting the headsetoption manually to Jabra. Is there a way to automate the whole process without the need of manual configuartion first ? "

 

Thanks in advance,

 

 

Message 7 of 9
SteffenBaierUK
Polycom Employee & Community Manager

Re: up.analogHeadset problem

Hello all,

 

when provisioning the phone add:

 

<device device.set="1" device.serial.enable.set="1" device.serial.enable="0" />

 

This issue will be addressed in a future Software Version (keep an eye on the release notes)

 

Best Regards

 

Steffen Baier

----------------
The title Polycom Employee & Community Manager is a community setting and does not reflect my role. I am just a simple volunteer in the community like everybody else. All posts and words are my own & do not represent the views of Employer.

----------------

Notice: This community forum is not an official Poly support resource, thus responses from Poly employees, partners, and customers alike are best-effort in attempts to share learned knowledge. If you need immediate and/or official assistance please open a service ticket through your proper support channels.
Please also ensure you always check the VoIP , Video Endpoint , Skype for Business , PSTN or RPM FAQ's
Message 8 of 9
escaux
Visitor

Re: up.analogHeadset problem

Dear,

 

It works perfectly, thank you !

Message 9 of 9