Plantronics + Polycom. Now together as Poly Logo

up.analogHeadsetOption is not working for me

Fraberonline
Visitor

up.analogHeadsetOption is not working for me

I tried to configure the up.analogHeadsetOption setting to automatically setup the Electronic Hookswitch to Plantronics (value 2). Unfortunately this is not working. Other settings in the UP section works perfectly fine.

 

I'm using firmware 3.3.1 on my Polycom IP331

 

Can someone please help me with this? This is part of my config file:

 

  <up up.headsetMode="0" up.onHookDialingEnabled="1" up.analogHeadsetOption="2" />

Message 1 of 8
7 REPLIES 7
SteffenBaierUK
Polycom Employee & Community Manager

Re: up.analogHeadsetOption is not working for me

Hello Fraberonline,

 

welcome to the Polycom Community.

 

You provided the Information that you are using UCS 3.3.1 on your SPIP331.

 

The up.onHookDialingEnabled is a SpectraLink 8400 Series only.

 

If 0, on hook dialing is disabled.

If 1, on-hook dialing is enabled.

 

This Parameter has only been introduced in UCS 4.0.0 and is only for the WiFi Spectralink 8400 Series.

 

In addition the up.headsetMode="0" 

 

If set to 1, the headset will be selected as the preferred transducer after its first use until the headset key is pressed again; otherwise,hands-free will be selected preferentially over the headset.

 

What would you like to do with the Parameter as you set it to it's Standard Value?

 

Can you elaborate in more detail what is actually not working in order for members of the community trying to help you configure your Headset.

 

In addition Polycom prepared a Headset compatibility list => here <= highlighting the supported Headset's and the adapter cables needed.

 

I would strongly recommend you read the UCS 3.3.0 Admin Guide => here <= and the document explaining the simplification of Configuration Improvements since UC Software 3.3.0 => here <=.

 

I cannot stress the importance of using FTP as a provisioning server in order to enable the upload of Phone logs in addition to the FTP append functionality as looking through the logs would have shown you the Parameter that is not working in your UC Software Version.

 

If you still struggle to troubleshoot your issue you may want to consider contacting your Polycom Reseller, if the units are still within warranty, or work with Polycom Support via PPI (Pay Per Incident).

 

Best regards 

 

Steffen Baier

 

Polycom Global Services 

 

----------------
The title Polycom Employee & Community Manager is a community setting and does not reflect my role. I am just a simple volunteer in the community like everybody else. My official "day" Job is 3rd Level support at Poly but I am unable to provide official support via the community.

----------------

Notice: This community forum is not an official Poly support resource, thus responses from Poly employees, partners, and customers alike are best-effort in attempts to share learned knowledge. If you need immediate and/or official assistance please open a service ticket through your proper support channels.
Please also ensure you always check the VoIP , Video Endpoint , Skype for Business , PSTN or RPM FAQ's
Message 2 of 8
SteffenBaierUK
Polycom Employee & Community Manager

Re: up.analogHeadsetOption is not working for me

Hello fraberonline,

 

did above Instructions help you with your issue?

 

Please leave some feedback for other community members or mark the topic as solution so they can profit from the Information provided.

 

Best Regards

 

Steffen Baier

 

Polycom Global Services

----------------
The title Polycom Employee & Community Manager is a community setting and does not reflect my role. I am just a simple volunteer in the community like everybody else. My official "day" Job is 3rd Level support at Poly but I am unable to provide official support via the community.

----------------

Notice: This community forum is not an official Poly support resource, thus responses from Poly employees, partners, and customers alike are best-effort in attempts to share learned knowledge. If you need immediate and/or official assistance please open a service ticket through your proper support channels.
Please also ensure you always check the VoIP , Video Endpoint , Skype for Business , PSTN or RPM FAQ's
Message 3 of 8
Fraberonline
Visitor

Re: up.analogHeadsetOption is not working for me

No, it didn't help at all. Because it was not an answer to my question. My problem is that the option  up.analogHeadsetOption="2" this should set it the Polycom IP331 to the applications-module but it doesn't change the setting in the phone. I have to change it by hand on every phone.

 

 

Message 4 of 8
SteffenBaierUK
Polycom Employee & Community Manager

Re: up.analogHeadsetOption is not working for me

Hello Fraberonline,

 

without actually knowing that the phone has loaded and applied the changed configuration troubleshooting is going to be difficult.

 

Please check the newly created FAQ about Log Files => here <= and confirm your setup has actually loaded a changed configuration and the phone has accepted the Parameter.

 

Best regards

 

Steffen Baier

 

Polycom Global Services

----------------
The title Polycom Employee & Community Manager is a community setting and does not reflect my role. I am just a simple volunteer in the community like everybody else. My official "day" Job is 3rd Level support at Poly but I am unable to provide official support via the community.

----------------

Notice: This community forum is not an official Poly support resource, thus responses from Poly employees, partners, and customers alike are best-effort in attempts to share learned knowledge. If you need immediate and/or official assistance please open a service ticket through your proper support channels.
Please also ensure you always check the VoIP , Video Endpoint , Skype for Business , PSTN or RPM FAQ's
Message 5 of 8
Fraberonline
Visitor

Re: up.analogHeadsetOption is not working for me

Hallo Steffen,

 

To me it looks more like a bug. The other options in the  <up  up.headsetMode="0"> section work fine. The only option that doesn't work is the  <up up.analogHeadsetOption="2"> This should work, there a manual on this specific setting for setting up the Electronic hornfilter.

 

Best regards

 

Frank

Message 6 of 8
SteffenBaierUK
Polycom Employee & Community Manager

Re: up.analogHeadsetOption is not working for me

Hello Frank,

 

not having spend to much time with this as the Community is not the official Support Platform I can confirm that using SIP 3.2.5 the Parameter up.analogHeadsetOption set's the Option in the Menu.

 

UC Software 3.3.1 and 3.3.2 seem to ignore this but show a changed Parameter in the Service Status Menu.

 

I would recommend you work with your Polycom Reseller and/or Polycom Support and log this as a Bug.

 

This is the correct way to do this and ensure you provide all your configuration files used and a complete Log.

 

The attached <mac>-app.log only contains 1 Line.

 

Please ensure that you follow the Guide I posted above to ensure that you have a complete set of Logs for Support to work with.

 

Best regards

 

Steffen Baier

 

Polycom Global Services

----------------
The title Polycom Employee & Community Manager is a community setting and does not reflect my role. I am just a simple volunteer in the community like everybody else. My official "day" Job is 3rd Level support at Poly but I am unable to provide official support via the community.

----------------

Notice: This community forum is not an official Poly support resource, thus responses from Poly employees, partners, and customers alike are best-effort in attempts to share learned knowledge. If you need immediate and/or official assistance please open a service ticket through your proper support channels.
Please also ensure you always check the VoIP , Video Endpoint , Skype for Business , PSTN or RPM FAQ's
Message 7 of 8
Fraberonline
Visitor

Re: up.analogHeadsetOption is not working for me

Oke thanks! I'll report it through a reseller.

 

Best Regards,

 

Frank

Message 8 of 8