Plantronics + Polycom. Now together as Poly Logo

upgrade VVX 400 / 500 to 5.2.2

fixthispolycom
Occasional Advisor

Re: upgrade VVX 400 / 500 to 5.2.2

I realize this is was a 5.2.2 thread but I'm hitting exact same error message on 5.4.2

 

UC Software Version 5.4.2.0334

Updater Version 5.6.2.0170

 

can't upgrade or downgrade via ftp or http or https (both split and combined) didn't try ftps but i doubt it'll behave differently

 

in the middle of requests to my http server the phone app log shows it still making a call to try to downloads.polycom and erroring out, now i have to fake dns entry to get that sorted...

 

 

tried the set to lync and back to generic tricks too

01942.774|utilm|4|00|uBLFUnCompressed: File /ffs0/Config/Local/WebTicket/0/sip.usr doesn't exist or is empty
001942.783|so |4|00|Could not find IP address for SNTP server. DnsRetryPeriod 86400
001942.820|copy |*|00|Server '10.xxx.xxx.63' said 'phone/544combined/MYMAC-calls.xml' is not present
001942.898|copy |*|00|Server '10.xxx.xxx.63' said 'phone/544combined/MYMAC-directory.xml' is not present
001942.918|clist|4|00|dbSet::srv2mem:'MYMAC-directory.xml' File transfer failed, trying to get local file
001942.941|copy |*|00|Server 'downloads.polycom.com' said 'voice/software/3111-46161-001.sip.ld' is not present
001942.945|cfg |*|00|Prov|Starting to update voice/software/sip.ld
001943.002|clist|4|00|dbSet::load:cleared load error state m_sync=<0x40>
001943.046|copy |*|00|Server '10.xxx.xxx.63' said 'phone/544combined/000000000000-directory.xml' is not present
001943.070|clist|4|00|dbSet::srv2mem:'000000000000-directory.xml' File transfer failed, trying to get local file
001943.072|copy |*|00|Server 'downloads.polycom.com' said 'voice/software/sip.ld' is not present
001943.141|copy |*|00|Server '10.xxx.xxx.63' said 'phone/544combined/MYMAC-phone.cfg' is not present
001943.228|copy |*|00|Server '10.xxx.xxx.63' said 'phone/544combined/MYMAC-web.cfg' is not present
001943.315|copy |*|00|Server '10.xxx.xxx.63' said 'phone/544combined/MYMAC-license.cfg' is not present
001943.334|copy |*|00|Server '10.xxx.xxx.63' said 'phone/544combined/MYMAC-license.cfg' is not present
001943.354|cfg |*|00|Prov|Finished updating configuration
Message 21 of 29
SteffenBaierUK
Polycom Employee & Community Manager

Re: upgrade VVX 400 / 500 to 5.2.2

Hello fixthispolycom,

I am unsure why you are stating there is an issue on our server end => here <= when I already multiple times throughout this topic explained that the software used by the users bringing up this issue had a defect (VOIP-98950)

 

In regards to your unrelated to this topic issue have you checked a backup of your configuration if by any chance either a server has been set or the DHCP server provides that address ?

Please ensure to provide some feedback if this reply has helped you so other users can profit from your experience.

Best Regards

Steffen Baier

Polycom Global Services

----------------
The title Polycom Employee & Community Manager is a community setting and does not reflect my role. I am just a simple volunteer in the community like everybody else. All posts and words are my own & do not represent the views of Employer.

----------------

Notice: This community forum is not an official Poly support resource, thus responses from Poly employees, partners, and customers alike are best-effort in attempts to share learned knowledge. If you need immediate and/or official assistance please open a service ticket through your proper support channels.
Please also ensure you always check the VoIP , Video Endpoint , Skype for Business , PSTN or RPM FAQ's
Message 22 of 29
fixthispolycom
Occasional Advisor

Re: upgrade VVX 400 / 500 to 5.2.2

sry edited above while u replied, attached log

 

(btw can't see contents of jira VOIP-98950)

 

01942.774|utilm|4|00|uBLFUnCompressed: File /ffs0/Config/Local/WebTicket/0/sip.usr doesn't exist or is empty
001942.783|so |4|00|Could not find IP address for SNTP server. DnsRetryPeriod 86400
001942.820|copy |*|00|Server '10.xxx.xxx.63' said 'phone/544combined/MYMAC-calls.xml' is not present
001942.898|copy |*|00|Server '10.xxx.xxx.63' said 'phone/544combined/MYMAC-directory.xml' is not present
001942.918|clist|4|00|dbSet::srv2mem:'MYMAC-directory.xml' File transfer failed, trying to get local file
001942.941|copy |*|00|Server 'downloads.polycom.com' said 'voice/software/3111-46161-001.sip.ld' is not present
001942.945|cfg |*|00|Prov|Starting to update voice/software/sip.ld
001943.002|clist|4|00|dbSet::load:cleared load error state m_sync=<0x40>
001943.046|copy |*|00|Server '10.xxx.xxx.63' said 'phone/544combined/000000000000-directory.xml' is not present
001943.070|clist|4|00|dbSet::srv2mem:'000000000000-directory.xml' File transfer failed, trying to get local file
001943.072|copy |*|00|Server 'downloads.polycom.com' said 'voice/software/sip.ld' is not present
001943.141|copy |*|00|Server '10.xxx.xxx.63' said 'phone/544combined/MYMAC-phone.cfg' is not present
001943.228|copy |*|00|Server '10.xxx.xxx.63' said 'phone/544combined/MYMAC-web.cfg' is not present
001943.315|copy |*|00|Server '10.xxx.xxx.63' said 'phone/544combined/MYMAC-license.cfg' is not present
001943.334|copy |*|00|Server '10.xxx.xxx.63' said 'phone/544combined/MYMAC-license.cfg' is not present
001943.354|cfg |*|00|Prov|Finished updating configuration
Message 23 of 29
fixthispolycom
Occasional Advisor

Re: upgrade VVX 400 / 500 to 5.2.2

while i'm sure faking a dns A record entry for downloads.polycom.com to return my lan IP will fix that remaining query, I can't 'easily' do that in all remote locations, home offices etc, seems a little .htaccess/redirect magic would fix this easily on your end

Message 24 of 29
SteffenBaierUK
Polycom Employee & Community Manager

Re: upgrade VVX 400 / 500 to 5.2.2

Hello fixthispolycom,

again, I believe somewhere in your configuration you set to use downloads.polycom.com and therefore the phone only looks on your local FTP where the configuration is located but uses "our" hosted server to download the actual firmware.

 

As the root directory does not contain such software and only the software version subdirectories do it cannot find it.

 

We offer the device.prov.upgradeServer or device.prov.serverName that can be used but without you checking your own backup I am unable to tell.

 

I am unsure why you obscured your MAC address as this would enable me to check who your Polycom reseller would be in order to provide you with 1st Level support and/or open a Polycom support ticket for you.

Please ensure to provide some feedback if this reply has helped you so other users can profit from your experience.

Best Regards

Steffen Baier

Polycom Global Services

----------------
The title Polycom Employee & Community Manager is a community setting and does not reflect my role. I am just a simple volunteer in the community like everybody else. All posts and words are my own & do not represent the views of Employer.

----------------

Notice: This community forum is not an official Poly support resource, thus responses from Poly employees, partners, and customers alike are best-effort in attempts to share learned knowledge. If you need immediate and/or official assistance please open a service ticket through your proper support channels.
Please also ensure you always check the VoIP , Video Endpoint , Skype for Business , PSTN or RPM FAQ's
Message 25 of 29
fixthispolycom
Occasional Advisor

Re: upgrade VVX 400 / 500 to 5.2.2

well random website sellers, no provisioning server (till the one just created), just simple sip account info

 

single field in the webui is currently pointed to my lan server...

 

however there are a few references to those entries in Config/site.cfg Config/polycomConfig.xsd Config/device.cfg I can try tweaking (but some entries are for the software upgrade tab > polycom hosted vs custom)

 

 

trying the clear upgrade server method

Successfully cleared the Upgrade Server configuration, From now onwards phone uses Provisioning Server for software image.

Message 26 of 29
SteffenBaierUK
Polycom Employee & Community Manager

Re: upgrade VVX 400 / 500 to 5.2.2

Hello fixthispolycom,

it could even be the  APP_FILE_PATH="sip.ld" section within the <mac>.cfg but only you can check this.

 

I can lookup the reseller we provided the phone to in order for you to get support from them if the unit is up to a year or less old.

Please ensure to provide some feedback if this reply has helped you so other users can profit from your experience.

Best Regards

Steffen Baier

Polycom Global Services

----------------
The title Polycom Employee & Community Manager is a community setting and does not reflect my role. I am just a simple volunteer in the community like everybody else. All posts and words are my own & do not represent the views of Employer.

----------------

Notice: This community forum is not an official Poly support resource, thus responses from Poly employees, partners, and customers alike are best-effort in attempts to share learned knowledge. If you need immediate and/or official assistance please open a service ticket through your proper support channels.
Please also ensure you always check the VoIP , Video Endpoint , Skype for Business , PSTN or RPM FAQ's
Message 27 of 29
fixthispolycom
Occasional Advisor

Re: upgrade VVX 400 / 500 to 5.2.2

all good / resolved

 

UC Software Version 5.4.4.2473 Updater Version 5.6.4.2075

 

 

noticed somehow it was sill using an upgrade server field rather than using the provisioning server (and clear upgrade server was grayed out already)

 

toggled it from poly>custom, rebooted, custom>poly, rebooted,(cleared my web-browser cache chrome50), poly>custom, rebooted - then clear showed up

 

(for extra measure changed all referenes i could find/grep for in my 5.4.4 http directory, but may have not been necessary at that point - tired of all the rebooting by then so figured i'd tackel both - thus one of the above methods resolved it)

 

 

 

 
Message 28 of 29
MegaByte Andorra
Occasional Visitor

Re: upgrade VVX 400 / 500 to 5.2.2

Hi,

 

I have the same problem but it's easy to fix, select custom server and paste http://downloads.polycom.com/voice/software/3111-44500-001.xml select the correct version and clic install.

 

Best regards,

Message 29 of 29