Plantronics + Polycom. Now together as Poly Logo

Poly Studio X50 - USB Device Mode on but not usable till powercycle

SteffenBaierUK
Polycom Employee & Community Manager

Re: Poly Studio X50 - USB Device Mode on but not usable till powercycle

Hello @Akeem ,

 

Welcome back to the Poly Community.


Standard cables to use with the Studio X series are USB-A to USB-C. USB a on a PC/Mac end and USB C on the Studio X end.

 

USB-A to -A cables are not usually delivered with standard applications and must be purchased seperaterly.

 

The USB-A Port(s) on a Studio X series are for USB stick's and/or mice/keyboard

 

Please ensure to provide some feedback if this reply has helped you so other users can profit from your experience.

Best Regards

Steffen Baier

----------------
The title Polycom Employee & Community Manager is a community setting and does not reflect my role. I am just a simple volunteer in the community like everybody else. All posts and words are my own & do not represent the views of Employer.

----------------

Notice: This community forum is not an official Poly support resource, thus responses from Poly employees, partners, and customers alike are best-effort in attempts to share learned knowledge. If you need immediate and/or official assistance please open a service ticket through your proper support channels.
Please also ensure you always check the VoIP , Video Endpoint , Skype for Business , PSTN or RPM FAQ's
Message 11 of 14
jamisono
Occasional Visitor

Re: Poly Studio X50 - USB Device Mode on but not usable till powercycle

I have this same issue.  Has there been any resolution?

Message 12 of 14
SteffenBaierUK
Polycom Employee & Community Manager

Re: Poly Studio X50 - USB Device Mode on but not usable till powercycle

Hello @jamisono ,

 

Welcome to the Poly Community.


As stated >here< was this reported to our support organization? What is the Software version you are using?

 

Please ensure to provide some feedback if this reply has helped you so other users can profit from your experience.

Best Regards

Steffen Baier

----------------
The title Polycom Employee & Community Manager is a community setting and does not reflect my role. I am just a simple volunteer in the community like everybody else. All posts and words are my own & do not represent the views of Employer.

----------------

Notice: This community forum is not an official Poly support resource, thus responses from Poly employees, partners, and customers alike are best-effort in attempts to share learned knowledge. If you need immediate and/or official assistance please open a service ticket through your proper support channels.
Please also ensure you always check the VoIP , Video Endpoint , Skype for Business , PSTN or RPM FAQ's
Message 13 of 14
Jon Ragnar
Occasional Advisor

Re: Poly Studio X50 - USB Device Mode on but not usable till powercycle

Hey!

 


We have a issue that seems the same 

 

Got the Poly branded USB-A - USB-C cable but the Usb-C does not fit properly into the codec!

 

The black metal piece around the connector is to big for the hole. Anyone have something similar??

Message 14 of 14