Plantronics + Polycom. Now together as Poly Logo

Devices not showing in Teams Admin Center

SOLVED
TrentQ
Occasional Advisor

Devices not showing in Teams Admin Center

Hi

 

I have several Poly CCX 400 and none will show in the Teams Admin Center, any ideas? The device is logged in and working.

 

Thanks

Trent

Message 1 of 13
1 ACCEPTED SOLUTION

Accepted Solutions
TrentQ
Occasional Advisor

Re: Devices not showing in Teams Admin Center

I've managed to get this working.

  1. Factory reset phone.
  2. Upgrade using USB from v1 to 6.2.22.0185
  3. Turn on the web admin on the phone.
  4. Upgrade to v6.2.23.0304
  5. Sign in on device itself
  6. Device working
  7. Upgrade firmware to latest via web admin
  8. Now working and showing in Teams Admin Centre

 

No changes we made on the Microsoft side at all, have been able to reproduce this on 3 different poly devices and different users. The only real change is the firmware, again no changes made on the Microsoft side to get this working.

 

Thanks

View solution in original post

Message 13 of 13
12 REPLIES 12
SteffenBaierUK
Polycom Employee & Community Manager

Re: Devices not showing in Teams Admin Center

Hello @TrentQ ,

Welcome back to the Poly Community.

It is always useful to include the currently used UC Software version as issues experienced or a question asked may already be addressed in a newer release.

Please also include if you are using this in Microsoft Teams Mode or in Skype for Business mode.

The above is also stated in the "Must Read First" and is the absolute minimum requirement every new post should include.


Please ensure to provide some feedback if this reply has helped you so other users can profit from your experience.

Best Regards

Steffen Baier

----------------
The title Polycom Employee & Community Manager is a community setting and does not reflect my role. I am just a simple volunteer in the community like everybody else. My official "day" Job is 3rd Level support at Poly but I am unable to provide official support via the community.

----------------

Notice: This community forum is not an official Poly support resource, thus responses from Poly employees, partners, and customers alike are best-effort in attempts to share learned knowledge. If you need immediate and/or official assistance please open a service ticket through your proper support channels.
Please also ensure you always check the VoIP , Video Endpoint , Skype for Business , PSTN or RPM FAQ's
Message 2 of 13
TrentQ
Occasional Advisor

Re: Devices not showing in Teams Admin Center

Hi Steffen

 

Version: 6.2.22.0185

 

Teams mode.

 

Thanks

Trent.

Message 3 of 13
SteffenBaierUK
Polycom Employee & Community Manager

Re: Devices not showing in Teams Admin Center

Hello @TrentQ ,

 

This is not a supported version. the current UC Software 7.0.3 is hosted in the Microsoft TAC and should be used.

 

If the issue still appears please work with our partner Microsoft who hosts the Microsoft Teams platform and provides manufacturers like Poly and others with the Microsoft Teams IP Phone app and the other apps running on our phones for Microsoft Teams integration.

 

Please ensure to provide some feedback if this reply has helped you so other users can profit from your experience.

Best Regards

Steffen Baier

----------------
The title Polycom Employee & Community Manager is a community setting and does not reflect my role. I am just a simple volunteer in the community like everybody else. My official "day" Job is 3rd Level support at Poly but I am unable to provide official support via the community.

----------------

Notice: This community forum is not an official Poly support resource, thus responses from Poly employees, partners, and customers alike are best-effort in attempts to share learned knowledge. If you need immediate and/or official assistance please open a service ticket through your proper support channels.
Please also ensure you always check the VoIP , Video Endpoint , Skype for Business , PSTN or RPM FAQ's
Message 4 of 13
TrentQ
Occasional Advisor

Re: Devices not showing in Teams Admin Center

As these devices aren't showing in the Tams Admin Centre I can't upgrade them.

 

Is there a USB firmware upgrade option for this?

Message 5 of 13
SteffenBaierUK
Polycom Employee & Community Manager

Re: Devices not showing in Teams Admin Center

Hello @TrentQ ,

 

From our general VoIP FAQ:

 

Oct 7, 2011 Question: How can I setup my Phone / Provisioning / Download / Upgrade / Update / Downgrade Software?
Resolution: Please check => here <=

 

Dec 04, 2015 Question:How can I provision/upgrade the software via USB for the Poly Trio, CCX and/or Visual+?

Resolution: Please check this post => here <=

 

Please ensure to provide some feedback if this reply has helped you so other users can profit from your experience.

Best Regards

Steffen Baier

----------------
The title Polycom Employee & Community Manager is a community setting and does not reflect my role. I am just a simple volunteer in the community like everybody else. My official "day" Job is 3rd Level support at Poly but I am unable to provide official support via the community.

----------------

Notice: This community forum is not an official Poly support resource, thus responses from Poly employees, partners, and customers alike are best-effort in attempts to share learned knowledge. If you need immediate and/or official assistance please open a service ticket through your proper support channels.
Please also ensure you always check the VoIP , Video Endpoint , Skype for Business , PSTN or RPM FAQ's
Message 6 of 13
TrentQ
Occasional Advisor

Re: Devices not showing in Teams Admin Center

I've read both articles and it would seem the answer is no, it cannot be upgraded via USB beyond v6.2.22.0185.

 

Is that correct?

 

Thanks

Message 7 of 13
SteffenBaierUK
Polycom Employee & Community Manager

Re: Devices not showing in Teams Admin Center

Hello @TrentQ ,

 

  • Visit our support page and download the preferred software
  • Unzip the file
  • Copy the file with all its structure to a USB Stick which has been Fat32 formatted
  • Put the USB Stick into the Phone
  • Follow the instructions

 

Please ensure to provide some feedback if this reply has helped you so other users can profit from your experience.

Best Regards

Steffen Baier

----------------
The title Polycom Employee & Community Manager is a community setting and does not reflect my role. I am just a simple volunteer in the community like everybody else. My official "day" Job is 3rd Level support at Poly but I am unable to provide official support via the community.

----------------

Notice: This community forum is not an official Poly support resource, thus responses from Poly employees, partners, and customers alike are best-effort in attempts to share learned knowledge. If you need immediate and/or official assistance please open a service ticket through your proper support channels.
Please also ensure you always check the VoIP , Video Endpoint , Skype for Business , PSTN or RPM FAQ's
Message 8 of 13
TrentQ
Occasional Advisor

Re: Devices not showing in Teams Admin Center

Thanks, I downloaded the latest firmware for CCX 400, extracted the zip and copied all the files and folders to a FAT2 USB, I put the USB into the phone but nothing has come up on the screen of the phone.

 

Thanks

Trent.

Message 9 of 13
SteffenBaierUK
Polycom Employee & Community Manager

Re: Devices not showing in Teams Admin Center

Hello @TrentQ ,

 

Please check that the Web Interface is enabled:

 

Apr 1, 2020 Question: How can I enable the Web Interface on a Poly phone running in Teams mode?

Resolution: Please check >here<

 

Once this is done copy all the data from the 1st Page after the Password logon and reply to here so we can see the details of the unit.

 

If there is no Web Interface:

 

Dec 02,2020 Question: Why can I not enable the Web Interface of a CCX 400 as described for other phones?

Resolution: The CCX 400 may be running software 1.0.0 or 1.0.1 and needs to be upgraded as described >here< in order to enable the Web Interface and many other features.


Please ensure to provide some feedback if this reply has helped you so other users can profit from your experience.

Best Regards

Steffen Baier

----------------
The title Polycom Employee & Community Manager is a community setting and does not reflect my role. I am just a simple volunteer in the community like everybody else. My official "day" Job is 3rd Level support at Poly but I am unable to provide official support via the community.

----------------

Notice: This community forum is not an official Poly support resource, thus responses from Poly employees, partners, and customers alike are best-effort in attempts to share learned knowledge. If you need immediate and/or official assistance please open a service ticket through your proper support channels.
Please also ensure you always check the VoIP , Video Endpoint , Skype for Business , PSTN or RPM FAQ's
Message 10 of 13