Plantronics + Polycom. Now together as Poly Logo

Paging (i.e. auto answer) not working after upgrade to 4.x.x

SOLVED
Occasional Visitor

Re: Paging (i.e. auto answer) not working after upgrade to 4.x.x

I'm on FreePBX 2.11 with Polycom SoundPoint 331s and firmware version 4.0.11. I have tried multiple settings for alertInfo in my sip.cfg and have not been able to get this to work. The receiving party's phone will just ring twice and hang up. It will not auto answer.

 

sip configurations I have tried:

<voIpProt.SIP.alertInfo voIpProt.SIP.alertInfo.1.class="ringAutoAnswer" voIpProt.SIP.alertInfo.1.value="Auto Answer"/>
<voIpProt.SIP.alertInfo voIpProt.SIP.alertInfo.1.class="ringAutoAnswer" voIpProt.SIP.alertInfo.1.value="Ring Answer"/>
<voIpProt.SIP.alertInfo voIpProt.SIP.alertInfo.1.class="ringAutoAnswer" voIpProt.SIP.alertInfo.1.value="4"/>

 

 

Here is my asterisk log:

  -- Executing [2666@app-pagegroups:6] Gosub("SIP/2341-00000716", "app-paging,ssetup,1()") in new stack
    -- Executing [ssetup@app-paging:1] Set("SIP/2341-00000716", "_SIPURI=") in new stack
    -- Executing [ssetup@app-paging:2] Set("SIP/2341-00000716", "_ALERTINFO=Alert-Info: Ring Answer") in new stack
    -- Executing [ssetup@app-paging:3] Set("SIP/2341-00000716", "_CALLINFO=Call-Info: <uri>;answer-after=0") in new stack
    -- Executing [ssetup@app-paging:4] Set("SIP/2341-00000716", "_SIPURI=intercom=true") in new stack
    -- Executing [ssetup@app-paging:5] Set("SIP/2341-00000716", "_DOPTIONS=A(beep)") in new stack
    -- Executing [ssetup@app-paging:6] Set("SIP/2341-00000716", "_DTIME=5") in new stack
    -- Executing [ssetup@app-paging:7] Set("SIP/2341-00000716", "_ANSWERMACRO=") in new stack
    -- Executing [ssetup@app-paging:8] Set("SIP/2341-00000716", "PAGE_CONF=1476301507740") in new stack
    -- Executing [ssetup@app-paging:9] Return("SIP/2341-00000716", "") in new stack
    -- Executing [2666@app-pagegroups:7] Set("SIP/2341-00000716", "PAGEMODE=FPAGE") in new stack
    -- Executing [2666@app-pagegroups:8] Set("SIP/2341-00000716", "PAGE_MEMBERS=2333") in new stack
    -- Executing [2666@app-pagegroups:9] Set("SIP/2341-00000716", "PAGE_CONF_OPTS=1dqsxm") in new stack
    -- Executing [2666@app-pagegroups:10] AGI("SIP/2341-00000716", "page.agi") in new stack
    -- Launched AGI Script /var/lib/asterisk/agi-bin/page.agi
    -- Executing [s@app-page-stream:1] Wait("Local/s@app-page-stream-00000271;2", "1") in new stack
    -- Executing [PAGE2333@app-paging:1] Macro("Local/PAGE2333@app-paging-00000272;2", "autoanswer,2333") in new stack
    -- Executing [s@app-page-stream:1] Wait("Local/s@app-page-stream-00000273;2", "1") in new stack
    -- Executing [s@macro-autoanswer:1] Set("Local/PAGE2333@app-paging-00000272;2", "DIAL=SIP/2333") in new stack
    -- Executing [s@macro-autoanswer:2] ExecIf("Local/PAGE2333@app-paging-00000272;2", "0?Set(DIAL=DAHDI/2333)") in new stack
    -- Executing [s@macro-autoanswer:3] GotoIf("Local/PAGE2333@app-paging-00000272;2", "0?macro") in new stack
    -- Executing [s@macro-autoanswer:4] Set("Local/PAGE2333@app-paging-00000272;2", "phone=PolycomSoundPointIP-SPIP_331-UA/4.0.11.0583") in new stack
    -- Executing [s@macro-autoanswer:5] ExecIf("Local/PAGE2333@app-paging-00000272;2", "0?Set(CALLINFO=Call-Info: <sip:broadworks.net>;answer-after=0)") in new stack
    -- Executing [s@macro-autoanswer:6] ExecIf("Local/PAGE2333@app-paging-00000272;2", "0?Set(ALERTINFO=Alert-Info: Intercom)") in new stack
    -- Executing [s@macro-autoanswer:7] ExecIf("Local/PAGE2333@app-paging-00000272;2", "1?Set(ALERTINFO=Alert-Info: info=Auto Answer)") in new stack
    -- Executing [s@macro-autoanswer:8] ExecIf("Local/PAGE2333@app-paging-00000272;2", "0?Set(ALERTINFO=Alert-Info: ring-answer)") in new stack
    -- Executing [s@macro-autoanswer:9] ExecIf("Local/PAGE2333@app-paging-00000272;2", "1?SipAddHeader(Alert-Info: info=Auto Answer)") in new stack
    -- Executing [s@macro-autoanswer:10] ExecIf("Local/PAGE2333@app-paging-00000272;2", "1?SipAddHeader(Call-Info: <uri>;answer-after=0)") in new stack
    -- Executing [s@macro-autoanswer:11] ExecIf("Local/PAGE2333@app-paging-00000272;2", "1?Set(__SIP_URI_OPTIONS=intercom=true)") in new stack
    -- Executing [PAGE2333@app-paging:2] Dial("Local/PAGE2333@app-paging-00000272;2", "SIP/2333,5,A(beep)") in new stack
  == Using SIP VIDEO TOS bits 136
  == Using SIP VIDEO CoS mark 6
  == Using SIP RTP TOS bits 184
  == Using SIP RTP CoS mark 5
    -- <SIP/2341-00000716>AGI Script page.agi completed, returning 0
    -- Called SIP/2333
    -- Executing [2666@app-pagegroups:11] MeetMe("SIP/2341-00000716", "1476301507740,dqwxAG,,") in new stack
    -- Created MeetMe conference 1023 for conference '1476301507740'
    -- SIP/2333-00000717 is ringing
    -- Executing [s@app-page-stream:2] Answer("Local/s@app-page-stream-00000271;2", "") in new stack
       > Channel Local/s@app-page-stream-00000271;1 was answered.
       > Launching Wait(5) on Local/s@app-page-stream-00000271;1
    -- Executing [s@app-page-stream:2] Answer("Local/s@app-page-stream-00000273;2", "") in new stack
       > Channel Local/s@app-page-stream-00000273;1 was answered.
       > Launching Playback(beep) on Local/s@app-page-stream-00000273;1
    -- <Local/s@app-page-stream-00000273;1> Playing 'beep.gsm' (language 'en')
    -- Executing [s@app-page-stream:3] MeetMe("Local/s@app-page-stream-00000273;2", "1476301507740,xq,,") in new stack
    -- Executing [s@app-page-stream:3] MeetMe("Local/s@app-page-stream-00000271;2", "1476301507740,xqA,,") in new stack
  == Spawn extension (app-page-stream, s, 3) exited non-zero on 'Local/s@app-page-stream-00000273;2'
    -- Nobody picked up in 5000 ms
    -- Executing [PAGE2333@app-paging:3] Hangup("Local/PAGE2333@app-paging-00000272;2", "") in new stack

 

Any help is greatly appreciated.

Message 21 of 29
Polycom Employee & Community Manager

Re: Paging (i.e. auto answer) not working after upgrade to 4.x.x

Hello Abel408,

welcome to the Polycom Community.

The community's VoIP FAQ contains this post here:

Oct 25, 2011 Question: How can I change my Ringtone or Ring in a special manner for a certain incoming call?

Resolution: Please check => here <=

 

and 

 

Jan 19, 2012 Question: How to troubleshoot Polycom VoIP related Issues?

Resolution: Please check => here <=

 

The above shows how you can use the phone logs to troubleshoot this issue.

 

Please follow this up and then post the logs if required.


Please ensure to provide some feedback if this reply has helped you so other users can profit from your experience.

Best Regards

Steffen Baier

Polycom Global Services




<======== Signature / Disclaimer ========>
Please be aware:For questions about the type of support to expect please check here

Please also ensure you always check the VoIP , Video Endpoint , Skype for Business , PSTN or RPM FAQ's

Please remember, if you see a post that helped you , and it answers your question, please mark it as an "Accept as Solution".

The title Polycom Employee & Community Manager is an automatic setting within the community and any forum reply or post is based upon my personal experience and does not reflect the opinion or view of my employer.
Poly employee participation within this community is not mandatory and any post or FAQ article provided by myself is done either during my working hours or outside working hours, in my private time, and maybe answered on weekends, bank holidays or personal holidays.
Message 22 of 29
Occasional Visitor

Re: Paging (i.e. auto answer) not working after upgrade to 4.x.x

Thanks  Steffen. Ok, so here is what my phone log reads when I try to call the page group I created in FreePBX:

 

 

1018112330|sip  |0|03|    INVITE sip:2333@10.131.16.197;intercom=true SIP/2.0
1018112330|sip  |0|03|    Via: SIP/2.0/UDP 10.131.16.33:5060;branch=z9hG4bK7bb15ff8
1018112330|sip  |0|03|    Max-Forwards: 70
1018112330|sip  |0|03|    From: "My Phone" <sip:2341@10.131.16.33>;tag=as02d6f163
1018112330|sip  |0|03|    To: <sip:2333@10.131.16.197;intercom=true>
1018112330|sip  |0|03|    Contact: <sip:2341@10.131.16.33:5060>
1018112330|sip  |0|03|    Call-ID: 01381f0647ce6f7054ed62b067fb3e8b@10.131.16.33:5060
1018112330|sip  |0|03|    CSeq: 102 INVITE
1018112330|sip  |0|03|    User-Agent: FPBX-2.11.0(11.21.0)
1018112330|sip  |0|03|    Date: Tue, 18 Oct 2016 15:23:30 GMT
1018112330|sip  |0|03|    Allow: INVITE, ACK, CANCEL, OPTIONS, BYE, REFER, SUBSCRIBE, NOTIFY, INFO, PUBLISH, MESSAGE
1018112330|sip  |0|03|    Supported: replaces, timer
1018112330|sip  |0|03|    Call-Info: <uri>;answer-after=0
1018112330|sip  |0|03|    Alert-Info: info=Auto Answer
1018112330|sip  |0|03|    Content-Type: application/sdp
1018112330|sip  |0|03|    Content-Length: 627

 

 

Does this mean FreePBX is sending "info=Auto Answer" as the alert-info for paging? Do I want to set the alertInfo value to "info=Auto Answer"?

Message 23 of 29
Polycom Employee & Community Manager

Re: Paging (i.e. auto answer) not working after upgrade to 4.x.x

Hello Able1408,

Please use:

 

<voIpProt.SIP.alertInfo voIpProt.SIP.alertInfo.1.class="ringAutoAnswer" 
voIpProt.SIP.alertInfo.1.value="Auto Answer"/>


Please ensure to provide some feedback if this reply has helped you so other users can profit from your experience.

Best Regards

Steffen Baier

Polycom Global Services




<======== Signature / Disclaimer ========>
Please be aware:For questions about the type of support to expect please check here

Please also ensure you always check the VoIP , Video Endpoint , Skype for Business , PSTN or RPM FAQ's

Please remember, if you see a post that helped you , and it answers your question, please mark it as an "Accept as Solution".

The title Polycom Employee & Community Manager is an automatic setting within the community and any forum reply or post is based upon my personal experience and does not reflect the opinion or view of my employer.
Poly employee participation within this community is not mandatory and any post or FAQ article provided by myself is done either during my working hours or outside working hours, in my private time, and maybe answered on weekends, bank holidays or personal holidays.
Message 24 of 29
Occasional Visitor

Re: Paging (i.e. auto answer) not working after upgrade to 4.x.x

Thanks Steffen, 

I've figured out the probem. I was adding the configurations you had mentions to my sip.cfg file. On FreePBX, the configuration needs to go in the mac_reg.cfg file. Must be an issue with the order that the config files are loaded.

Message 25 of 29

Re: Paging (i.e. auto answer) not working after upgrade to 4.x.x

I realise this is a very old post but I cannot find the answer anywhere either.

I have a vvx301 and I can set the phone to auto-answer ALL calls with:

call.autoAnswer.SIP="1"

But I only want the phone to auto-answer calls we send from OneVoice as Paging calls.

 

I have tried various flavours of 

<voIpProt.SIP.alertInfo voIpProt.SIP.alertInfo.1.class="ringAutoAnswer" voIpProt.SIP.alertInfo.1.value="Auto Answer"/>

 

 

 

Message 26 of 29
Polycom Employee & Community Manager

Re: Paging (i.e. auto answer) not working after upgrade to 4.x.x

Hello @Rus Yates-Aylott,

welcome to the Polycom Community.

It is always useful to include the currently used UC Software version as issues experienced or a question asked may already be addressed in a newer release.

This also allows yourself and others to check against current software release notes, Administrator Guides or FAQ post’s.

The above is also stated in the "Must Read First" and is the absolute minimum requirement every new post should include. .

In addition providing us with this basic information gives Polycom an idea what Software Versions are used in the field and avoids wasting time trying to troubleshoot issues which have already been addressed.

Therefore the Polycom VoIP FAQ contains this post here:

Question: How can I find out my SIP or UC Software Version of my Phone?
Resolution: Please check here

 

In addition as you already stated the functionality you used will answer "every" call.

 

The FAQ contains this:

 

Oct 25, 2011 Question: How can I change my Ringtone or Ring in a special manner for a certain incoming call?

Resolution: Please check => here <=

 

The above explains in detail on how to utilise and also how to troubleshoot this.


Please ensure to provide some feedback if this reply has helped you so other users can profit from your experience.

Best Regards

Steffen Baier

Polycom Global Services




<======== Signature / Disclaimer ========>
Please be aware:For questions about the type of support to expect please check here

Please also ensure you always check the VoIP , Video Endpoint , Skype for Business , PSTN or RPM FAQ's

Please remember, if you see a post that helped you , and it answers your question, please mark it as an "Accept as Solution".

The title Polycom Employee & Community Manager is an automatic setting within the community and any forum reply or post is based upon my personal experience and does not reflect the opinion or view of my employer.
Poly employee participation within this community is not mandatory and any post or FAQ article provided by myself is done either during my working hours or outside working hours, in my private time, and maybe answered on weekends, bank holidays or personal holidays.
Message 27 of 29

Re: Paging (i.e. auto answer) not working after upgrade to 4.x.x

Hi.

Thanks for the response but I cannot see a solution to my concern.

I do NOT want to set Auto-answer for every incoming call, only if I am receiving a paging call from the kazoo/freeswitch platform (which, of course, could orginate from a non-polycom device) 

Message 28 of 29
Polycom Employee & Community Manager

Re: Paging (i.e. auto answer) not working after upgrade to 4.x.x

Hello

As explained in detail if your SIP server is capable of sending a specific SIP INFO HEADER per call the phone will Auto Answer or whatever choice you make in the configuration.

Replied via a mobile device



<======== Signature / Disclaimer ========>
Please be aware:For questions about the type of support to expect please check here

Please also ensure you always check the VoIP , Video Endpoint , Skype for Business , PSTN or RPM FAQ's

Please remember, if you see a post that helped you , and it answers your question, please mark it as an "Accept as Solution".

The title Polycom Employee & Community Manager is an automatic setting within the community and any forum reply or post is based upon my personal experience and does not reflect the opinion or view of my employer.
Poly employee participation within this community is not mandatory and any post or FAQ article provided by myself is done either during my working hours or outside working hours, in my private time, and maybe answered on weekends, bank holidays or personal holidays.
Message 29 of 29