Plantronics + Polycom. Now together as Poly Logo

Trio 8800 no video with Freeswitch bridge

Occasional Visitor

Trio 8800 no video with Freeswitch bridge

Is there any known Trio 8800 settings to enable video-calls to a Freeswitch 1.8.5 server?

It previously worked when we were using Freeswitch 1.6.20, but stopped working after upgrade with the exact same Freeswitch config. I take it some sort of default settings or behaviour changed.

Sniffing UDP-packets, I see that the Trio receive video packets but doesn't seem to send any.

 

The Freeswitch transcode all video feeds into one output /conference. If I call Freeswitch from our other softphones, the video transcoding works fine.

 

 

Polycom Trio 8800 firmware version 5.8.0.15232. Codec H264 is first on the list under video codec priority.

 

Message 1 of 8
7 REPLIES 7
Occasional Visitor

Re: Trio 8800 no video with Freeswitch bridge

Correction, the video negotiation fails completely and no video is sent in either direction. I have 2 SDP calls below. The Trio fails with a=inactive while the other one succeds Trio 8800 invite to Freeswitch 

 

v=0 o=- 460289138 460289139 IN IP4 1.2.3.4 s=x c=IN IP4 1.2.3.4 t=0 0 
m=audio 22482 RTP/AVP 107 8 0 101 
a=rtpmap:107 opus/48000/2 
a=fmtp:107 maxplaybackrate=16000;sprop-maxcapturerate=16000;maxaveragebitrate=24000 
a=rtpmap:8 PCMA/8000 a=rtpmap:0 PCMU/8000 
a=rtpmap:101 telephone-event/8000 
a=fmtp:101 0-16 
a=ptime:20 
a=maxptime:20 
m=video 20592 RTP/AVP 99 a=rtpmap:99 H264/90000 
a=fmtp:99 max-mbps=245760;max-fs=8196;packetization-mode=0;profile-level-id=428029 
m=video 0 RTP/AVP 1 

Freeswitch to Trio 8800

v=0 o=FreeSWITCH 1551856696 1551856698 IN IP4 1.2.3.5 
s=FreeSWITCH 
c=IN IP4 1.2.3.5 t=0 0 
m=audio 29618 RTP/AVP 107 101 a=rtpmap:107 opus/48000/2 
a=fmtp:107 useinbandfec=1 a=rtpmap:101 telephone-event/8000 
a=fmtp:101 0-16 a=ptime:20 
m=video 23646 RTP/AVP 99 b=AS:819200 
a=rtpmap:99 H264/90000 
a=fmtp:99 max-mbps=245760;max-fs=8196;packetization-mode=0;profile-level-id=428029 
a=inactive m=video 0 RTP/AVP 19 

---------------Call #2 -------------------
Softphone invite to Freeswitch

 

v=0 o=- 1489309910 1489309910 IN IP4 1.2.3.4 s=x 
c=IN IP4 1.2.3.4 t=0 0 m=audio 22634 RTP/AVP 107 9 8 0 101 
a=rtpmap:107 opus/48000/2 
a=fmtp:107 maxaveragebitrate=64000;useinbandfec=1;usedtx=1 
a=rtpmap:9 G722/8000 a=rtpmap:8 PCMA/8000 
a=rtpmap:0 PCMU/8000 a=rtpmap:101 telephone-event/8000 
a=fmtp:101 0-16 a=ptime:20 
a=maxptime:20 m=video 25912 RTP/AVP 99 
a=rtpmap:99 H264/90000 
a=fmtp:99 packetization-mode=0;profile-level-id=42801F 

Freeswitch to softphone

v=0 o=FreeSWITCH 1551855851 1551855852 IN IP4 1.2.3.5 
s=FreeSWITCH c=IN IP4 1.2.3.5 t=0 0 m=audio 30748 RTP/AVP 107 101 
a=rtpmap:107 opus/48000/2 a=fmtp:107 useinbandfec=1 a=rtpmap:101 telephone-event/8000 
a=fmtp:101 0-16 
a=ptime:20 
m=video 21696 RTP/AVP 99 b=AS:819200 
a=rtpmap:99 H264/90000 
a=fmtp:99 packetization-mode=0;profile-level-id=42801F
Message 2 of 8
Highlighted
Polycom Employee & Community Manager

Re: Trio 8800 no video with Freeswitch bridge

Hello @Jay2221 ,

 

welcome to the Polycom Community.

Both the community's Must Read First and the community's FAQ reference the basic minimum information a new or follow up post should contain.

This ensures the questions having to be asked are limited and any new or follow up post contains the right amount of details to ensure any voluntary participant within the community does not spend additional time chasing basic information.

As a reminder the basic information asked for:

 

  • Provide the exact Software Version of your Phone
  • Provide the Phone Model
  • Provide the Call Platform (aka openSIP,Skype for Business Online, Skype for Business on Premise, Lync)
  • Additional Polycom Infrastructure (RPRM,PDMS or BToE)
  • If applicable provide a backup of the phone in question

UC Software 4.0.0 or later via the Web Interface Utilities > Phone Backup & Restore > Phone Backup > Phone Backup. Please rename into .TXT or Zip the file to attach.
Since UC Software 5.9.0 simply provide this via the Web Interface Diagnostics > Download Support Information Package

  • If possible provide a Log and either attach them or use the Code Tag.Consult the Troubleshooting Section found within the FAQ if applicable
  • If possible provide the MAC Address or Serial of the device
  • Provide details for example if the issue is a day 1 issue or only happened after an upgrade or any other relevant details
  • For questions around Support please check here

 

Whilst providing some of these details may not directly impact any possible answer the community can provide, it does enable Polycom to have an overview of the current software used. In addition providing all details at the same time allow us to check logs or look up a potential support partners if an issue needs to come into support. It also enables us to verify the entitlement for using features.

 

I did try and add some formatting to your original post but in reality for anyone to comment we would need a proper log or a wireshark trace.


Please ensure you always check the FAQ's and/or utilize the community search before posting any new topics or follow up post’s.

 

Jan 19, 2012 Question: How to troubleshoot Polycom VoIP related Issues?

Resolution: Please check => here <=

 

Please ensure you follow the above and provide the relevant details when replying.


Please ensure to provide some feedback if this reply has helped you so other users can profit from your experience.

Best Regards

Steffen Baier

Polycom Global Services




<======== Signature / Disclaimer ========>
Please be aware:For questions about the type of support to expect please check here

Please also ensure you always check the VoIP , Video Endpoint , Skype for Business , PSTN or RPM FAQ's

Please remember, if you see a post that helped you , and it answers your question, please mark it as an "Accept as Solution".

The title Polycom Employee & Community Manager is an automatic setting within the community and any forum reply or post is based upon my personal experience and does not reflect the opinion or view of my employer.
Poly employee participation within this community is not mandatory and any post or FAQ article provided by myself is done either during my working hours or outside working hours, in my private time, and maybe answered on weekends, bank holidays or personal holidays.
Message 3 of 8
Occasional Visitor

Re: Trio 8800 no video with Freeswitch bridge

This looks more like a bug in Freeswitch when the traffic passes a FS gateway in between A and B. The original SDP from Trio is not the same as the one the receiving FS gets, and I assume the "m=video 0" is causing the problem. I will take it up with Freeswitch instead. Thanks.
Message 4 of 8
Occasional Visitor

Re: Trio 8800 no video with Freeswitch bridge

To clarify: The SDP packet exceeded the MTU 1500 byte and was cut.
Message 5 of 8
Occasional Visitor

Re: Trio 8800 no video with Freeswitch bridge

I got a response back from Freeswitch that the Trio unit is sending invalid SDP. Trio is sending m=video x RTP/AVP 99 on both video-streams which is not allowed according to RFC. Any comment on this ?
Message 6 of 8
Polycom Employee & Community Manager

Re: Trio 8800 no video with Freeswitch bridge

Hello @Jay2221 ,

 

we would need to see this in support.

 

In order to raise a support ticket you need to work with your Polycom reseller as they need to do this for you.

End Customers are unable to open a ticket directly with Polycom support.

If this is some sort of an Internet discounter providing your MAC address or your Polycom devices serial will enable us to look up who would be able to support you. This may not be who you purchased the Polycom device from.

If the unit is no longer within warranty please be prepared to Pay Per Incident / PPI. This is all outlined in detail here

Please ensure to provide some feedback if this reply has helped you so other users can profit from your experience.

Best Regards

Steffen Baier

Polycom Global Services




<======== Signature / Disclaimer ========>
Please be aware:For questions about the type of support to expect please check here

Please also ensure you always check the VoIP , Video Endpoint , Skype for Business , PSTN or RPM FAQ's

Please remember, if you see a post that helped you , and it answers your question, please mark it as an "Accept as Solution".

The title Polycom Employee & Community Manager is an automatic setting within the community and any forum reply or post is based upon my personal experience and does not reflect the opinion or view of my employer.
Poly employee participation within this community is not mandatory and any post or FAQ article provided by myself is done either during my working hours or outside working hours, in my private time, and maybe answered on weekends, bank holidays or personal holidays.
Message 7 of 8
Occasional Visitor

Re: Trio 8800 no video with Freeswitch bridge

Did u resolve this issue?

Message 8 of 8