Reply
ITs
Occasional Visitor
Posts: 3
0
Accepted Solution

SoundStation IP 6000 tls

[ Edited ]

Software Version:    tested 4.0.10.0689 and 4.0.4.2906

 

Impossible to register to a 3CX PBX v15.5 using TLS 5061, the normal way 5060 udp is working.

We've got other phones, yealink brand and they are working with tls with this pbx.

NTP and DNS is working but this error still appears in the logs.

We successfully import the certificate on the phone and changed ports to 5061 and lines appers on the logs:

0808144730|sip |4|03|Server certificate verification failed, Untrusted Cetificate
0808144730|sip |4|03|MakeTlsConnection: SSL_connect error 1
0808144730|sip |4|03|MakeTlsConnection: connection failed error -1


We've disabled certificate verification and the error still appears and the device doesn't register.

Thanks in advance.

Polycom Employee & Community Manager
Posts: 13,757
0

Re: SoundStation IP 6000 tls

Hello  ITs,

welcome to the Polycom Community. Both of your software versions are no longer supported and you should do all testing using 4.0.12

The community's VoIP FAQ contains this post here:

 

Apr 17, 2013 QuestionHow can I setup a TLS connection for SIP signaling and / or troubleshoot this?

Resolution: Please check => here <=

 

The above contains troubleshootings steps and an example configuration.

 

The next step is to utilize the logging and post more logs and the used configuration.

Please ensure to provide some feedback if this reply has helped you so other users can profit from your experience.

Best Regards

Steffen Baier

Polycom Global Services

Please be aware:

The purpose of these forums is to allow community members collaborate and help each other.
Questions posted here do not follow Polycom’s SLA guidelines.
If you require assistance from Polycom technical support, please open a
web service request or call us .

The above is necessary in order to track issue internally within Polycom.

You are welcome to post more questions or configuration or logs for other community members to look at but if your issue requires a fix via Polycom you must go via the official support structure.

Please ensure you always check the VoIP , Video Endpoint , Skype for Business , PSTN or RPM FAQ's

Please remember, if you see a post that helped you , and it answers your question, please mark it as an "Accept as Solution".

This forum reply or post is based upon my personal experience and does not reflect the opinion or view of my employer.
Polycom employee participation within this community is not mandatory and any post or FAQ article provided by myself is done either during my working hours or outside working hours, in my private time, and may be answered on weekends, bank holidays or personal holidays.
ITs
Occasional Visitor
Posts: 3
0

Re: SoundStation IP 6000 tls

Hi Stephen,

I updated to 4.0.12.0926 and the problem persist, I generated the certificate as per http://community.polycom.com/t5/VoIP/FAQ-How-can-I-setup-a-TLS-connection-for-SIP-signaling-and-or/t... and imported but we still getting

 

 

0809111406|sip  |4|03|Server certificate verification failed, Untrusted Cetificate
0809111406|sip  |4|03|MakeTlsConnection: SSL_connect error 1
0809111406|sip  |4|03|MakeTlsConnection: connection failed error -1

 

Do you have any clue how can I fix it?

Thanks in advance.

Highlighted
Polycom Employee & Community Manager
Posts: 13,757
0

Re: SoundStation IP 6000 tls

Hello  ITs,

Yet again you did not post any logs with the relevant logging levels as described in the FAQ itself so you are unable to see what the phone is complaining about.

 

You need to change the logging level and follow the FAQ.

 

If you still struggle following the FAQ please open a ticket.


In order to raise a support ticket you need to work with your Polycom reseller as they need to do this for you. End Customers are usually unable to open a ticket directly with Polycom support.

If this is some sort of an Internet discounter please post either your phone's MAC address or your Polycom devices serial so I can look up who would be able to support you. This may not be who you purchased the Polycom device from.

Please ensure to provide some feedback if this reply has helped you so other users can profit from your experience.

Best Regards

Steffen Baier

Polycom Global Services

Please be aware:

The purpose of these forums is to allow community members collaborate and help each other.
Questions posted here do not follow Polycom’s SLA guidelines.
If you require assistance from Polycom technical support, please open a
web service request or call us .

The above is necessary in order to track issue internally within Polycom.

You are welcome to post more questions or configuration or logs for other community members to look at but if your issue requires a fix via Polycom you must go via the official support structure.

Please ensure you always check the VoIP , Video Endpoint , Skype for Business , PSTN or RPM FAQ's

Please remember, if you see a post that helped you , and it answers your question, please mark it as an "Accept as Solution".

This forum reply or post is based upon my personal experience and does not reflect the opinion or view of my employer.
Polycom employee participation within this community is not mandatory and any post or FAQ article provided by myself is done either during my working hours or outside working hours, in my private time, and may be answered on weekends, bank holidays or personal holidays.
ITs
Occasional Visitor
Posts: 3
0

Re: SoundStation IP 6000 tls

today 3CX released a new version, I applied and now it works, I have TLS working, for information Im using:

 

3CX PBX 15.5.3849.1 and firmware 4.0.12.0926