Plantronics + Polycom. Now together as Poly Logo

VVX 1500 with ipv6 is totally broken

hw
Advisor

VVX 1500 with ipv6 is totally broken

Hi,

 

don't the VVX phones support ipv6?  I see the settings for ipv6 in the menu, but no matter what I try, the best result is that the phone registers with asterisk and not a second later, it is unreachable.  Many times, the phone says that DHCPv6 failed, but there are no issues with DHCP with other devices on the network.

 

Is there any way to get the phone to work ipv6 and asterisk?  It's been working fine with ipv4.

 

Message 1 of 13
12 REPLIES 12
SteffenBaierUK
Polycom Employee & Community Manager

Re: VVX 1500 with ipv6 is totally broken

Hello @hw ,

 

Welcomeback to the Poly Community.

Both the communities Must Read First and the FAQ reference the basic minimum information a new or follow-up post should contain.

This ensures the questions having to be asked are limited and any new or follow-up post contains the right amount of details to ensure any voluntary participant within the community does not spend additional time chasing basic information.

As a reminder the basic information asked for:

UC Software 4.0.0 or later via the Web Interface Utilities > Phone Backup & Restore > Phone Backup > Phone Backup. Please rename it into .TXT or Zip the file to attach.
Since UC Software 5.9.0 simply provide this via the Web Interface Diagnostics > Download Support Information Package

  • If possible provide a Log and either attach them or use the Code Tag.Consult the Troubleshooting Section found within the FAQ if applicable
  • If possible provide the MAC Address or Serial of the device
  • Provide details for example if the issue is a day 1 issue or only happened after an upgrade or any other relevant details
  • For questions around Support please check here

Whilst providing some of these details may not directly impact any possible answer the community can provide, it does enable Poly to have an overview of the current software used. In addition, providing all details at the same time allows us to check logs or look up potential support partners if an issue needs to come into support. It also enables us to verify the entitlement for using features.


Please ensure you always check the FAQs and/or utilize the community search before posting any new topics or follow up posts.


Please ensure to provide some feedback if this reply has helped you so other users can profit from your experience.

Best Regards

Steffen Baier

----------------
The title Polycom Employee & Community Manager is a community setting and does not reflect my role. I am just a simple volunteer in the community like everybody else. All posts and words are my own & do not represent the views of Employer.

----------------

Notice: This community forum is not an official Poly support resource, thus responses from Poly employees, partners, and customers alike are best-effort in attempts to share learned knowledge. If you need immediate and/or official assistance please open a service ticket through your proper support channels.
Please also ensure you always check the VoIP , Video Endpoint , Skype for Business , PSTN or RPM FAQ's
Message 2 of 13
hw
Advisor

Re: VVX 1500 with ipv6 is totally broken

Ok, here is some more information:

 

Phone Information
Phone ModelVVX 1500
Part Number2345-17960-001 Rev:D
MAC Address00:04:F2:BE:EC:56
IP ModeIPv4 and IPv6
IP AddressIPv4: 10.10.5.99 and IPv6: fe80::204:f2ff:febe:ec56
UC Software Version5.9.2.3446
Updater Version5.9.7.19340

 

I'm not sure what you mean by 'call platform'.  I'm using asterisk as PXB.

A sanitized diagnostic info is appended.

The MAC address is contained in the diagnostic and above.

The problem exists only when ipv6 is enabled, no matter wether ipv4 is enabled at the same time or not.

 

The information on https://community.polycom.com/t5/VoIP-SIP-Phones/FAQ-How-can-I-check-the-SIP-and-UCS-UC-Software-and... didn't help.

 

The information in the diagnostic might indicate that the phone doesn't figure out the address of the DNS server and can't figure out what the NTP server is.  I have a laptop connected to the same VLAN as the phone and thus have been able verify that DHCPv4 and DHCPv6 are working fine.

 

Asterisk shows the phone as unavailable, making a test call from the phone to a musiconhold extension does work.  The test calls shows that the phone is using its ipv4 address.  I have currently enforced, in pjsip_wizard.conf, that the phone must use the ipv6 transport, but it doesn't.  It doesn't matter if I don't specify the transport and let asterisk/the phone pick the transport; both ipv4 and ipv6 transports are available.

 

PS: Something is wrong with attaching files.  The forum says:

 

"The file type (.7z) is not supported. Valid file types are: jpg, gif, pdf, ppt, doc, png, jpeg, zip, .7z, docx, xlsx, pptx, wmv, flv, mp3, mp4, log, tgz, pbu, txt."

 

That's very contradictory.

 

Please see https://www.adminart.net/phone-diagnostic.tar.7z instead.

 

Message 3 of 13
SteffenBaierUK
Polycom Employee & Community Manager

Re: VVX 1500 with ipv6 is totally broken

Hello @hw ,

 

The software you are using is no longer supported as the latest is 5.9.6

 

I suggest you check:

 

Jul 06, 2016 Question:Do Poly IP Phones support IPv6?

Resolution: Please check => here <= for more details

 

Share some more logs once this is updated so other community members can try and help you.

 

Please ensure to provide some feedback if this reply has helped you so other users can profit from your experience.

Best Regards

Steffen Baier

----------------
The title Polycom Employee & Community Manager is a community setting and does not reflect my role. I am just a simple volunteer in the community like everybody else. All posts and words are my own & do not represent the views of Employer.

----------------

Notice: This community forum is not an official Poly support resource, thus responses from Poly employees, partners, and customers alike are best-effort in attempts to share learned knowledge. If you need immediate and/or official assistance please open a service ticket through your proper support channels.
Please also ensure you always check the VoIP , Video Endpoint , Skype for Business , PSTN or RPM FAQ's
Message 4 of 13
hw
Advisor

Re: VVX 1500 with ipv6 is totally broken

Thanks!  Hm, it's probably gona be a nightmare to update ... Where can find the latest firmware?  The list (https://support.polycom.com/content/support/north-america/usa/en/support/eol-products/vvx1500.html) ends with a 5.7.... version.

 

Message 5 of 13
SteffenBaierUK
Polycom Employee & Community Manager

Re: VVX 1500 with ipv6 is totally broken

Hello @hw 

 

according to our software matrix the VVX 1500 "should" run 5.9.5 >here< but from memory (these phones are super old) it should also run 5.9.6

 

Check https://support.polycom.com/content/support/north-america/usa/en/support/voice/business-media-phones...

 

It does contain the 2345-17960-001.sip.ld

 

Best regards

 

Steffen Baier

----------------
The title Polycom Employee & Community Manager is a community setting and does not reflect my role. I am just a simple volunteer in the community like everybody else. All posts and words are my own & do not represent the views of Employer.

----------------

Notice: This community forum is not an official Poly support resource, thus responses from Poly employees, partners, and customers alike are best-effort in attempts to share learned knowledge. If you need immediate and/or official assistance please open a service ticket through your proper support channels.
Please also ensure you always check the VoIP , Video Endpoint , Skype for Business , PSTN or RPM FAQ's
Message 6 of 13
hw
Advisor

Re: VVX 1500 with ipv6 is totally broken

Cool, so there is up-to-date sofware

 

Old or not, somehow I love this phone, and it doesn't appear old to me at all.  But now I'm afraid it's bricked: I switched it back to ipv4 only, allowed internet access and went into the web gui to check for updates on the Polycom server because it's so difficult to use my own server.  The latest software was found and I clicked on the Install button.  The phone was supposed to reboot and it didn't --- which isn't unusual, so I power-cycled it and now it tries to update and ends up with saying "No room for updater" and then reboots after saying "Application not present".

 

I disabled internet access again and now it's stuck saying 'Updating , Please wait'.  I turned it off for now ... What can I do?

 

Message 7 of 13
SteffenBaierUK
Polycom Employee & Community Manager

Re: VVX 1500 with ipv6 is totally broken

Hello @hw 


mid there no option to cancel the boot process?

 

replied via a mobile device 

----------------
The title Polycom Employee & Community Manager is a community setting and does not reflect my role. I am just a simple volunteer in the community like everybody else. All posts and words are my own & do not represent the views of Employer.

----------------

Notice: This community forum is not an official Poly support resource, thus responses from Poly employees, partners, and customers alike are best-effort in attempts to share learned knowledge. If you need immediate and/or official assistance please open a service ticket through your proper support channels.
Please also ensure you always check the VoIP , Video Endpoint , Skype for Business , PSTN or RPM FAQ's
Message 8 of 13
hw
Advisor

Re: VVX 1500 with ipv6 is totally broken

Hi Steffen,

 

the only options is the setup screen, and first I selected to format the file system --- after which it tried to update again, but after a while it failed again.  The other option is to delete the settings, but that also ends up in a reboot cycle, saying that the application is not present.

 

I guess "the application" has been deleted during the update, and the updater can't install the new one because it runs out of memory.  How is that even possible?  The description of the current software says it works with VVX 1500 phones, and updating the software through the web interface of the phone must not lead to destroying the phone.  After an experience like this, I can no longer buy, nor recommend phones from Polycom and instead can only warn about them.

 

Is there a way to fix this?  This is a very expensive phone and it was great when it worked.

 

Message 9 of 13
SteffenBaierUK
Polycom Employee & Community Manager

Re: VVX 1500 with ipv6 is totally broken

Hello @hw ,

 

Do you remember what Software Version you tried to upgrade?

 

In my 12 years with Poly I have never managed to kill a phone as we always have a failback option.

 

What Menu does the phone offer you are usually the BootROM / Updater menu should still be there even if the Application itself is deleted?

 

In this menu, you point your phone to a local FTP server ( do not use TFTP as I have had bad experiences with this) and point it to a user with the unzipped software. I would try and go back to 5.9.2

 

I have reported this to our product management team to remove the software for the VVX 1500 if this cannot be used to upgrade phones.


Please ensure to provide some feedback if this reply has helped you so other users can profit from your experience.

Best Regards

Steffen Baier

----------------
The title Polycom Employee & Community Manager is a community setting and does not reflect my role. I am just a simple volunteer in the community like everybody else. All posts and words are my own & do not represent the views of Employer.

----------------

Notice: This community forum is not an official Poly support resource, thus responses from Poly employees, partners, and customers alike are best-effort in attempts to share learned knowledge. If you need immediate and/or official assistance please open a service ticket through your proper support channels.
Please also ensure you always check the VoIP , Video Endpoint , Skype for Business , PSTN or RPM FAQ's
Message 10 of 13